Probable OpenAI Bug: Insufficient Quota Error on Paid Account with Available Balance

I’m helping a user out and they are in a Nordic country. Unlike in the USA, it seems that he has to “charge” his account with credit using his credit card. His account has $43 and some change in it that he paid with his credit card. The account is also more than 48 hours old so there is no RPD limit. But when he runs a request, OpenAI responds:

“error”: {
“message”: “You exceeded your current quota, please check your plan and billing details.”,
“type”: “insufficient_quota”,
“param”: null,
“code”: “insufficient_quota”

So I’m wondering if this has something to do with maybe how OpenAI is treating Nordic countries with the “charging” of their account. Maybe it’s not seeing the remaining balance or something? I can’t imagine he is the only one experiencing this issue.

Also, I had him open a second account, add his credit card, wait 48 hours, charge the account with some credits, and then after spending about $50 he gets the same error again, even though his account has around $16 left in it.

Just for clarification, the funds in his account are from his credit card. No free trial credits are being used.

I also had him reach out to chat support but they kept replying with nonsense “you might be in a free trial, please add a credit card” message.

Any ideas?


You can review the approved limit and hard limit setting of the accounts, especially one that has made multiple payments. The monthly allowance there is still in place, requiring a request on the linked page and waiting to have it increased.

I don’t expect it’s anything about the country. The balance is already in your account, there’s just a problem with the calculation or ability to spend it.

The support assistant (lower right of is designed to intercept and answer messages. You have to make it understood that OpenAI staff is required for the billing issue with your language, and it anecdotally may take on the timeframe of a week or more.

1 Like

That’s not it. His hard limit is $600. He’s not even close to that amount. He also has $43 and change remaining credit. I’ve attached a screenshot as I think this is a bug.

1 Like

I am also receiving the same issue. This has only started this week and I have also reached to support about this. I have not exceeded my rate limits or anywhere near my hard or soft limits. My account is several months old. Seems like something has changed recently


Have the same issue, the account has positive balance and limits not even close. Problem started from August 25 and still exists. I have tried create new API key, but nothing happens.


I am following up that OpenAI chat has simply responded again with their unhelpful boilerplate template:

Hi there,

Sorry you’re running into errors regarding hitting your quota usage! For context, quota refers to the monthly spend limit on our API.

If you are currently on our Explore plan, which is our free trial plan on the API, your quota limit is $5. In order to use the API further, please upgrade to our Pay-As-You-Go plan by adding your credit card and billing details to your account, which will increase your usage quota to $120/month. If you belong to multiple organizations, you might accidentally be in an org that is not on the Pay-As-You-Go plan, so change your default organization to control which organization is used by default when making requests with your API key.

If you’re a Pay-As-You-Go user, try:

increasing your hard quota limit if your Hard limit (a monthly usage threshold you can set) is less than your approved usage limit (maximum usage OpenAI allows for your organization each month).
requesting a quota increase if your hard limit equals your approved usage and has been reached. If you have already requested a quota increase, please hang tight for 1-3 business days as we review your request.

In the future, you can adjust your monthly soft limit so we send you a notification when you reach your soft limit and can plan for a quota increase if needed.

If these steps don’t resolve your issue, please provide more details, and I’ll be glad to help you further!

Support keeps sending back that response. But the proof is that screenshot. He is pay as you go, but the API continues to respond with:

    "error": {
        "message": "You exceeded your current quota, please check your plan and billing details.",
        "type": "insufficient_quota",
        "param": null,
        "code": "insufficient_quota"

1 Like

Anyone have an update to this? Really frustrating, and I doubt support will get back in reasonable time.


The only update is even more users arbitrarily unable to spend API credits they’ve paid for by the new prepayment system.

1 Like

I figured that’s what it was. Crazy for them to release a brand new billing system like this with such a ground breaking bug.

1 Like

Same problem!


I have exactly the same problem! The chat bot is useless


I have the same issue, and chat bot is not helping.

1 Like

1 Like

This seems to be a common issue some are facing, hopefully it is rectified soon.

The advice from the email still stands though :

  1. Make sure you are not in the first 48 hours.
  2. Make sure you have a credit card assigned to your account.
  3. Make sure you have selected the correct default Organisation from your API account management screen

Same here. Started using API in April. Balance in account, 0 usage for the past two days.

Hi folks. Your accounts may have been impacted by a delay in purchased credits being processed by our billing provider. We’re working with them to ensure this doesn’t happen again. Most accounts should be fixed now – can you try your API requests again?


Currently having this issue as well, I had no usage and wasnt able to use my API until I added credits. This has been an issue for about 3 days now. I was able to use it fine without adding credits ans paying as I go but now Im unable to.

1 Like

If you changed your payment method on your account (especially by removing the old card first or cancelling payment plan), and were required to make a prepayment in order to input the new card, you are now on the prepayment plan for the foreseeable future. You’ll need to pay ahead of time for your expected use.

1 Like

Okay, but I’m still unable to use my API key even before I charged my payment method, it kept telling me I had insufficient quota even though I had not used any.

Investigate the current credit balance you see on the main billing page. If you had usage for the month, credits would first go to paying off the existing account balance, possibly using all credits without any remaining. You need to pay the existing balance through this new system also as the old card is gone.