RateLimitError: You exceeded your current quota, please check your plan and billing details

That “anyone” is OpenAI staff that can be contacted by a message through the help.openai.com assistant. The AI of the assistant will try to answer “quota” problems with standard answers itself, so best you preface it as “account credit issue needs OpenAI staff to fix” or similar.

This bug has impacted many people, unable to spend all the credits they just bought since this new system just went into place. Make the amount of messages you send about them charging, and then not letting you spend, a trend on that assistant and maybe it will be fixed.

2 Likes

I have “messaged” the openAI team, still waiting for them to response

2 Likes

I got reply from OpenAI but did not help at all, it’s just a standard template. Were you able to fix it? If so, can you share how, thanks!

I solved this issue. You need add billing address in your account! Billing->Preferences->Primary business address.

2 Likes

Thank you, and just did, and looks like it’s still not working.

I did too and it didn’t solve the issue.

I filled a report to the support linking to multiple post here talking about this issue.

Feel free to do it too as it may bring attention to this issue and help everyone.

Here are a few links of post here talking about this.

they didn’t even answer me, I still haven’t solved it.

Hi,

Do you have a credit card linked to your account? If so, has it been linked for 48 hours or more?

Same issue, I have paid and trying but it still give the same error.

I see there is no way to contact their support team, AI :frowning:

This fixed the error for me. Who would have known that simply adding a billing address would resolve the quota error?! Thank you!!!

1 Like

Exactly. It’s a pleasure. :grinning: LOL

1 Like

Same issue here. first time user, put in some credit ($10 to get started)
updated my billing address and billing email, was still getting ‘openai.error.RateLimitError: You exceeded your current quota, please check your plan and billing details.’ (I’m using python library)

Turned on auto-recharge, lo and behold, it works ! :rofl: :moneybag:

Anyway, I was able to turn off auto-recharge directly afterwards and it still works. I hope this helps somebody !!

Possibly does an authorization against the card in the background to see if it’s good for future charges. and billing address seems key to all this being done properly. it’s just a guess :man_shrugging:

1 Like

Same thing with me, I used python and gradio, then used the new free API key 3.5 on a new account that had never used chatgpt before. I emailed OpenAi, they said “we are currently working on a repair” and told me to wait while it is repaired, but the API system status shows normal.

Same issue here. Really excited to start messing around with the Assistants, so hopefully they fix this soon!

Still seeing this issue. Is anyone looking into this?
I have been testing this with my old keys and I am getting this rate limit error.

First, although this says “rate limits”, the rest of the plan indicates your API account isn’t billable. Either you hit a hard limit or there aren’t funds available.

One thing that was done recently to accounts was to add a new organization “personal”. Maybe this was so that an OpenAI account doesn’t become completely useless if you assign another organization owner and then they remove you.

It also means you need to check which account organization is funded by credits or has rights for monthly billing, and make sure below API keys, that the correct default organization is selected. There’s an organization selection when you click your name icon at lower-left bar of platform.openai.com.

Also “add credits” and just wait a bit - because it actually might take time for the Stripe account management system to charge your card and unlock the account.

Does creating a new account with a new number have an effect on creating a free API key? which means, a fresh account has no API created and no usage limits?

I’m not even sure if they are still giving trial credits to new accounts, but only the first account associated with a phone number would have gotten those credits, last $5 of API credit expiring in three months.

A new account certainly has usage limits, you start at “free tier” with limitations such as only being able to make three API requests per minute. Then prepay of anything less than $50 gets you just to tier 1, with slower-generating AI models.

This thread and its “check your plan” error message is about just trying to use the API with no active credit balance at all for the API key.

import openai # import library openAI/ChatGPT
import gradio as gr # import library Gradio App
from gtts import gTTS # import libary agar konversi teks menjadi suara
import os
import pygame # import untuk memainkan audio

kode API Chatgpt

openai.api_key = “”

Inisialisasi Pesan

messages = [{“role”: “system”, “content”: “Hello, Welcome to ALICE, How Can I Help You?”}]

Inisialisasi pygame

pygame.init()

Inputan pertanyaan dari user

def api_chatgpt(Masukan):
messages.append({“role”: “user”, “content”: Masukan})
response = openai.ChatCompletion.create(
model=“gpt-3.5-turbo”,
messages=messages
)
jawab_bot = response[“choices”][0][“message”][“content”]
messages.append({“role”: “assistant”, “content”: jawab_bot})

# Konversi teks menjadi suara menggunakan gTTS
tts = gTTS(text=jawab_bot, lang="id")
audio_file = "hasil_Suara.mp3"
tts.save(audio_file)

# Memutarkan suara
os.system("start " + audio_file)  # Ini akan memainkan suara menggunakan aplikasi default untuk file audio di Windows

return jawab_bot, audio_file  # Mengembalikan teks dan file audio bersamaan

Inisialisasi Gradio APP sebagai Interface

hasil_output = gr.Interface(fn=api_chatgpt, inputs=“text”, outputs=[“text”, “audio”], title=“ALICE”)

Ubah teks “outputs” menjadi “audio” untuk menampilkan audio

Fungsi untuk memainkan audio

def play_audio(audio_file):
pygame.mixer.music.load(audio_file)
pygame.mixer.music.play()
while pygame.mixer.music.get_busy():
continue

Setel output agar memainkan audio

hasil_output.out = play_audio

Jalankan aplikasi Gradio

hasil_output.launch()

This is my code, I use Gradio and Python which can produce sound and text output.

Last month the API key still worked, when this month it was November 8th and I tried it the result was an error. then I got a notification to update the OpenAi version and was told v1.0.0 Migration.

I think my API key can still be used. because, I haven’t created the API key for a long time in this new account.

I recently checked the OpenAI usage on my account and it turns out it has expired, like this:

Screenshot 2023-11-12 133212

is this the cause? or have to migrate to that version?

by the way, i from indonesia

hey, so are your issues resolved or you’re still facing the issue?