429 Error : insufficient_quota

It has been 48 hours since I purchased credits and my dashboard shows none of the credits have been used, but the response from the API request is the following:

{
“error”: {
“message”: “You exceeded your current quota, please check your plan and billing details.”,
“type”: “insufficient_quota”,
“param”: null,
“code”: “insufficient_quota”
}
}

Head over to OpenAI Platform and set the monthly budget for your account. It seems that right now it’s only $10.

If you receive error 429, this means that the server might be overloaded because you’ve sent too many requests. The solution is to apply a retry and backoff function to your code.

Hey Kevin,

Thanks for the reply. I have set the budget at $50. I will add the retry and backoff function in the code and see if that works. I did test that out earlier, but I will try it again. What is the best way to go about implementing that?

Take look at this:
Nodejs:

https://help.openai.com/en/?q=429

So I set the maxRetries to 0 and it didn’t help. I did some searching and found out that it might be because of the stripe payment integration that OpenAI has. I don’t think any change to my code would help, because it is a simple function.

Even with postman I get the same response. It is just on OpenAI’s side. It is probably an issue in their backend.

I don’t think so, It’s just bad practice that openai would sync usage requests with strip.

I reached out to support and they said “thanks for the bug report”. I also posted it on github, but no one on github replied yet.

It looks like you’re in a monthly payment plan, have been billed at the end of the month before. Haven’t used any API.

This is the link that shows your current credit balance. Or shows your increasing pending invoice if you are on a monthly bill plan.

https://platform.openai.com/account/billing/overview

If it shows "You’ll be billed at the end of each calendar month for usage during that month." then the only thing that should hold you back is your billing limits, click usage limits there to see if you set a hard limit.

One thing that may stop you is that to some accounts like mine they recently added a different second organization out of the blue. Go to API keys, and at the bottom, make sure your original organization is selected and not a new one with nothing going on.

At the very bottom of the bar you click on your name icon, you’ll get a pop-up where you can switch organizations.

Thank you! You were right. I had the API key under ‘personal’, but I bought the credits with my student account.

Thank you my problem has been solved.

1 Like

I tried so hard to fix this only to find out that free credits expire after few months.

1 Like

I had the same problem, and API keys was also under ‘Personal’. In my case I had to choose ‘Personal’ again, beacuse there were no other option in my case. But it helped:)

I am also having this issue, but in Python. Tried at different times on different days and no luck.

Edit: It worked just now. Guess the connection is inconsistent even on paid plans.

Encountered this issue today with the playground - so no external API calls involved.

Had a negative balance shown of USD 1,38 - despite having my credit card against it. And this never happend in the last months of usage. I then up’d my balance by 10 USD manually with the same CC - and an hour later it worked again.

If I give my CC details, I expect the service to work until I reach my limit. This is not a behavior I expect from a professional grade service.

If it matters, I had renewed my CC a week ago set the new CC as default.

I was switched to Prepaid billing on February 20th. Today I bought $100 credits and I see them on my dashboard. I also set my monthly limit to $100.

Yet, right now I still get the message

You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs: https://platform.openai.com/docs/guides/error-codes/api-errors

How long does it usually take for credits to become available?

cheers
Oliver

Nevermind. After a few minutes it started working.

Thank you, that explains it. I also got the info, and they stated “no action is required from you at this time” - which was factually false.

I’ve waited 10min and still getting the quota error. Pretty slow response times. I’m going to bed, sad that I can’t test my project and will check in the morning…

I am facing this issue, please, someone help me with thi.

There are many causes of getting an error 429: “…check your plan and billing details”.

If your “issue” the same as 80%, it is because you have not purchased the API credits required to pay for API services.

https://platform.openai.com/settings/organization/billing/overview