You exceeded your current quota, please check your plan and billing details. On charged account

I have an account that was previously used successfully. The credits expired some time ago, and today I added a card, making a payment of $5. The new credit is now visible in my console.

Screenshot 2023-12-01 at 09-10-25 OpenAI Platform

My payment was accepted over two hours ago; however, I continue to receive the ‘You exceeded your current quota, please check your plan and billing details’ RateLimit error message.

Within my account, there is only one organization named ‘Personal,’ and I have provided my billing address in Billing Settings. The monthly limit is set to a maximum of $120, and auto-recharge is enabled. Despite creating a new key several times, the issue persists.

I reached out to OpenAI support, but their responses consist of generic copy-paste answers that do not address my problem. Moreover, they promptly close the conversation, requiring me to start anew each time they reply. Even after doing so, I received the same copy-paste response and a closed conversation.

I’ve explored similar topics on this forum, but none of the suggested solutions have worked for me. What other steps have I not yet attempted?

I’m having this same issue! It’s making me lose my mind.

1 Like

You can also check this thread for more solutions:

There are no more solutions in that thread. Just a flood of people having the same issue as I do.


I have sent three messages to the support. Two previous messages were replied with some links to FAQ, that I have seen before. Good to know that I am not alone with this. I propose everyone to send the request to support, probably this will initiate the fixing from their side.

I’m getting the same issue. Definitely a bug on OpenAI’s side

I also have the same problem, dont get answers… tried it in python and with assistants / playground. Always got exceedet quota (error 429). Billed 20 $

Me too, just to add to the growing list of evidence

1 Like

Same here, let’s hope they solved it asap. With this problem for about two hours.

1 Like

I have the same issue
{response: ‘{\n “error”: {\n “message”: "You exceeded …ll,\n “code”: “insufficient_quota”\n }\n}\n’}

I’ve got a reply from support: they are investigating the problem

Hey folks! I was tracking and replying in this thread: Probable OpenAI Bug: Insufficient Quota Error on Paid Account with Available Balance - #71 by logankilpatrick the issue has since been resolved, thanks for hanging in there with us.

1 Like