Invited to Team Workspace doesn't work

I invited someone (free user) to my team workspace. He clicket the “join workspace” in the invintation e-mail, but can’t use GPT4. It looks still like the free plan and aks him to update to GPT+. In the workspace omi can see the invintation is sent, but not joined the workspace yet. Is this a Bug? Anyone experience this too?

8 Likes

Thanks for your update and using the tag chatgpt-team. As I do not have access to a ChatGPT Team account, I find this to be valuable feedback.

As a moderator I will do what I can to get this noticed by the OpenAI staff.


In the meantime, consider asking in this topic, as other users who have ChatGPT Team might offer relevant feedback.

To other moderators: Please do not move this topic; we don’t need a mega thread. Moving it into a mega-thread makes the information harder to find and share.

1 Like

Same issue here. We create a Team company workspace to move all ChatGPT Plus users and avoid the billing nightmare with Plus users.
I received the Team invitation email but for some reason, my account was not added/updated to Team workspace.
Any advances on this topic?

We had the same problem here!
After opening a workspace for the whole company and taking 2 paying seats (the minimum required). We then sent an invitation to all our employees. They were able to join the workspace, but only the first 20.
In fact, by taking 2 seats, we were limited to a maximum of 20 employees.
Does anyone know whether this limit is proportional to the number of seats purchased?

For example :
2 seats corresponds to a maximum of 20 people
Would 3 seats mean 30 people?

1 Like

Yes, experiencing same here. Received the invite, clicked the link, but I am not appearing in the joined workspace.

1 Like

Update on the issue: After a few hours, I noticed that my account had been updated to display two options: our company workspace and my previous personal account. This indicates that the synchronization has now been successfully completed. However, I observed a delay in this update. It seems there is a lack of synchronization between the time the confirmation email is sent and the completion of all necessary background operations in the system. I hope OpenAI will address this timing discrepancy to improve the user experience in the future.

1 Like

Getting the exact same issue. No one can accept the invite after 20 users.

My partner signed up for a Teams account and sent me an invitation. However, after clicking the invite link and logging in, I’m still only able to access my personal account. From her side, the invitation status remains “pending”.

I’ve tried clearing the cache and using incognito mode, but no luck.

1 Like

any progress ? same issue here. Plese let me know if managed to solve!

I’m experiencing the same issue with my team workspace invitations.
A user is logged in with the correct email, but they do not see any option to switch to the team workspace in the menu.

When logged out, they see the message “You have been invited to the [team] workspace! Login or sign up with [correct email] to accept the invitation.”

Same issue here. After accepting the invite only personal account is showing. Also can see a notification for “Add a team plan” or similar (the regular ad)

We recently moved to Teams as well, and yes this was a bit problematic for us as well, but after countless times refreshing the website and trying different browsers it finally worked.

Here’s something more important that you should know (especially if you already had a Plus subscription on your account which you intend to move on the Teams plan):

  • When you invite an already subscription-activated account on Teams, you will quickly identify that you have two profiles i.e. one is called “Personal” and the second one is what you named your “Workspace”.

  • It may appear to some people that after paying $30 or $25 per month (based on your plan tenure) you are getting 40 messages on GPT4 on your personal account and 100 messages on your workspace account, totaling 140 messages per 3-hour limit, but it is not like THAT!

  • When you invite/move any existing account that has active subscription, you also carry forward that Plus subscription along with your Workspace account, so to ensure that you do not get billed for two subscriptions you need to navigate to your Workspace profile and go to the settings and navigate to Data Control tab, and click the Merge button, by doing so, all your previous chat history, custom gpts, and everything will be moved from your personal profile to the Workspace profile and you’ll instantly receive an email from OpenAI containing the last invoice you were charged for the Plus subscription and refund against the remaining days based on pro-rata calculation.

If you do not do this, common sense entails that you’ll be charged for a Plus subscription alongside the Teams subscription on renewal.

Hope you guys find this info useful.

1 Like

Hi, same problem here. After getting an invite for a team space and accepting it, only my personal account shows up. I’ve been invited 12 hours ago, so far nothing happened.

We are having the same problems here. As the owner, I have invited team members. But when they click join workspace, it still says they are a part of their free 3.5 version workspace, not our team (paid for) workspace.

Same problem. Did you guys sign up using OAuth (Microsoft SSO) as well?

I tested on my phone and was able to immediately see the Teams account. After accepting on my phone, Teams appeared on my desktop version. Try different devices.

Are users still seeing this problem?

The last user message was a week ago.

All good for us now. We’ve been steadily adding folks to our Team last several days now with no glitches. Thanks.

1 Like

I am experiencing this. Got an invite to join a workspace but nothing changes after clicking the link.

1 Like

I was invited to chat gpt team. got an email and everything but my account does not have access

1 Like