Can not make GPT public - no name shows up in builder profile

I’ve tied two sites to two Custom GPTs so far… the UI is a bit clunky, though, and I had to backtrack a bit, but it stuck…

Would be nice to be able to edit name, though…

I’ve had my domain verified but i’m still unable to publicly publish the GPT i’ve made (although I can share the link). The builder won’t let me toggle the website button to ‘on’ (despite showing the website). There is also no name option for me (image below).

Is anyone else seeing this problem / have any solutions?

Is name set in your billing profile? Might that be why it’s not showing up and it’s causing the website to fail?

I’ve set up my billing through apple pay - I can’t see anywhere on the Chat GPT interface to change name etc?

I can see my name appears on the Chat API page when i click billing (although i don’t have a payment set up for the API only for Chat GPT Plus - not sure if that matters?)

Yeah, I’m not sure, I’m just trying to troubleshoot. I think you would have to make sure it’s showing on billing… or there might be a problem with OpenAI seeing your billing details and it’s breaking their system? You might want to reach out to to let them know of your problems and all the details.

1 Like

For me it didn’t work.

The changes were not real time (had to wait a couple of minutes to make them visible).

But when I set GPT-1 to site-1 and GPT-2 to site-2, also GPT-1 was linked to site-2.

And I have two verified domains, both available in “not verified domains” (yeah…).

In the pulldown I do see both domains, but even when I click the second one, the checkmark stays on the first one.

And when I set a GPT to “public” a day later it’s reset to “private” (but still shows as public).

Lol, they can make the most advanced AI in the world, but simple bootstrapping a UI with decent UX is hard, it seems.

1 Like

Huh. I just checked, and you’re right. They’re all the second website I picked. Good catch!

Yeah, it would be nice if you could set both privacy and domain per GPT.

Now I have to publish all GPT’s under the same domain, but some of the GPT’s are corporate and others more fun-like.

So I decided to delete the fun-things. Don’t wanna associate them with a serious brand.

1 Like

I am also community builder and i dont have this option to key in my name. I dont have a website domain. Hope to get advice and help pls

  1. Yes. After they’re published publicly, you can edit them. I know because I can do so on my end. You can revert back to certain save state of the GPT by asking it " roll back changes to " description of that certain save state ". It kept on changing the profile picture without my permission. Once I typed this command/comment in the builder box " I love it. I want to keep it forever. So please don’t delete it when I’m making changes to instructions, descritpion, etc. ", it really kept it.

Yes, I’m having a similar issue, however, I am able to toggle the website to “On”, but when I got to publish publicly it tells me I’m not allowed to and to verify my domain in my settings. Please share if you figure out a resolution! I have a support ticket in and so waiting to learn more myself.

Similar issue since Friday, 11/10. No “name” toggle option and failing to verify my TXT record. Submitted a ticket also and hopefully it’ll be resolved soon.

1 Like

Domain issue solved… for domain verification, make sure the domain name that you’re trying to verify is something like ‘’ and not ‘’. I removed the original domain (with www.) and requested to resolve the domain without ‘www.’ and placed the new TXT record & value given into my DNS server (namecheap). Domain was immediately verified.

Still have the issue of not having the ‘Name’ option toggle.

Since I cant change the Community Builder author due to IOS and I don’t want to purchase a domain, I added my name next to the title of the GPT App (GPT App By John Doe), hopefully that will provide some recognition.

The only question I have is if the GPT Store opens, are only the public ones get paid? Opinions are welcome. Thanks.

Hey, so I looked further in to allowing public access and it seems there are plugins and Oauth is an option, accessed in actions. But still haven’t managed it, looked like a good option. But they ask you to create a plug in which is an option I don’t get. I can browse plugins and install but you need to create and I think openAI have stopped it with the new GPTs, or a bug. It maybe I don’t have developer privs, but I paid $20 for the plus subscription. I don’t see how to get the dev role unless it is under enterprise? Let me know if you get a chance to check it out. I am lookin at the openAI schema and other Oauth options too. Thanks !

Hey, so I signed up for developeer access, now on the wait list, here it is in case you’re interested…

Plugins have essentially been replaced with Actions, so I think joining that waitlist will be fruitless.

I still have this issue, I am unable to make my GPT’s public because I have no builder profile, and yet I can’t edit my builder profile. and have no option to toggle the name category on. The only thing I can add is a domain.

1 Like

Even I am facing the same hassle after I subscribed through Apple Pay.