[Solved] How to verify domain on Profile

Hi everyone, I am not a developer, and I just created a GPT. I might asking something silly…

First, I have a verified domain which was by GoDaddy.
Second, I created a website which was from Durable.
Third, I want my domain [ GoDaddy], and website [Durable] to get verified on my ChatGPT profile.

How could I do that?

I tried and it says I need [TXT Record], which GoDaddy says it’s not their business, I should go and ask [Durable], and I cannot find any useful sources on Durable.

So, if you also know any alternative source to create a website, please also let me know. And I really need help to verify the domain on my GPT profile. Thanks!


I copied this from another post who used gpt; as everyone does now :wink: I did this and it works. However my domain does not point to the gpt yet? Not sure why, it has been 24 hours and it may take 48 hours for the DNS to point to the GPT, so I am just waiting for now. But below will get your domain verified - good luck…

  1. Create an OpenAI Account: If you haven’t done so already, sign up for an account with OpenAI. This will give you access to the necessary tools and resources.
  2. Access Builder Dashboard: Once you have an OpenAI account, log in and navigate to the ‘Builder’ dashboard. This is where you can manage your GPT applications.
  3. Create a New Project: Start a new project for your GPT application. You’ll be prompted to enter basic information about your project, like its name and description.
  4. Configure Domain Settings:
    • To publish your GPTs publicly, you’ll need to have a domain name. If you don’t have one, purchase a domain from a registrar like GoDaddy, Namecheap, etc.
    • Once you have your domain, you need to verify ownership with OpenAI. This is where the TXT file comes in.
  5. Verify Domain Ownership:
    • OpenAI will provide you with a TXT record. This is a type of DNS (Domain Name System) record used to prove domain ownership.
    • Log in to your domain registrar’s control panel and navigate to the DNS settings section.
    • Add a new TXT record, pasting the value provided by OpenAI. The exact steps for this may vary depending on your domain registrar, but generally, you’ll need to specify the TXT record type, enter ‘@’ in the host field (or your domain), and paste the value from OpenAI in the value field.
    • Save your changes. It may take some time (up to 48 hours, usually less) for DNS changes to propagate.
  6. Wait for Verification: After adding the TXT record, return to the OpenAI Builder dashboard and confirm that you’ve added the record. OpenAI will then verify your domain, which may take a short while.
  7. Publish Your GPTs:
    • Once your domain is verified, you can proceed to publish your GPT applications.
    • Use the Builder tools to configure and customize your GPT model as per your requirements.
    • After setting it up, you can publish your GPT application. It will now be accessible publicly through your domain.
  8. Monitor and Update: Keep an eye on your GPT application for usage, performance, and feedback. Regularly update and maintain your application to ensure it functions smoothly.

I have the same problem, I can’t find the value for the TXT. Maybe it’s not yet available, maybe it will bacome available once they launch the GPTs store?

1 Like

It is possible when you click on the sharing button and then choosing “public” you have a little pen to click on it and then you are in the builder, then you will find things you need.

1 Like

Thank you! I think my question now is ‘Where can I find my TXT record?’ according to ‘OpenAI will provide you with a TXT record.’

I cannot find TXT record in the GPT nor the domain verify process. Thank you!


I am having an issue where I’ve added my TXT file to my domain and my openAI profile says my domain is verified, however, when I go to update my GPT to public, I get the notification that “Your changes couldn’t be published” and I need to connect my domain in my settings etc. Even though I already have… Do I just need to give it some time?

1 Like

Go to your name on the bottom left of your home page, then settings & beta, then builder profile, and then website, verify new domain and it should give it to you in a pop up.


Solved it. You can’t use safari. Try chrome or another browser.


On checking the verification, I get an error that it was not able to find the record however I am sure that I placed it correctly

TXT record at 3600 and the snippet into the value with the domain as empty or just “@”

Anyone having the same verification problem


Had the same issue. I just redid the whole thing. Deleting the domain, recreating it in the builder profile and entering a new value in the record worked for me. Also, have you checked your records manually? (Dig (DNS lookup))

solved it, just took a day or so and now it allows me to publish.

1 Like

I can’t activate this, no error messages… What to do?

Have you tried refreshing the entire page after verifying? It was being a bit weird with me too.


What is the right " TTL ", as i can’t choose “auto” ?


I am using bluehost for maintaining a domain and already created a TXT record copying the value from GPT. I have been waiting 3 days but when I click ‘check’ it stills shows my domain is not verified. Does anyone have the same issue or any possible solutions?


Refreshed, tried another browser, waited 2 days. Nothing :upside_down_face:

1 Like

Thanks for your list. Regarding point 7, it is not clear to me how the publication is performed. Thanks

I am facing the same issue… anyone found a solution?

It’s odd because when I check the DNS on Google’s DNS toolkit I see my verification code. Yet when I click to verify in OpenAI I get an error. Any solutions are welcome.

I have the exact same issue with bluehost. By chance did you figure it out?