My domain is verified and builder profile set up but can't save as 'public'

My domain is verified and builder profile set up but can’t save as ‘public’. It gives me the message to set up my builder profile which looks like it is to me.

Builder Profile is found in settings, from what I understand you need either the name or a verified website to be publicly visible.

That Name option isn’t there for me. The button for website is and looks verified. Can you click the information button there for me and show me what it says?

this is what mine looks like. I can’t figure out why it is different from other people.


Not sure what you’ve done differently, this is what the information icon displays though.

The support from Open AI is terrible .

1 Like

The user interface is obviously undergoing changes to facilitate the adding of proper information necessary to support future opening of a GPT store directory.

I would first close all but one ChatGPT window and tab, and then do a browser hard-refresh (which is shift-“refresh”, ctrl-f5, or similar, depending on the browser.). This should ensure the ChatGPT in-browser software is newest and communicating with what new options have been made available. That would let you see the current status of code.

Setting “Public” status at this point does nothing additional for you, as there is no public directory yet.

Changes are still needed. Published support email, for example, I note would need a significant change in method, as there is no situation where it is ideal to share a personal email used for the account itself.


they have made some changes. It now says ‘everyone’ instead of public but still doesn’t allow me to choose.
My builder profile screen now has this message however, i have done both of these things and it still doesn’t work

Hi! I found the way that domain verification works is not as expected. The verify in the settings->builder profile keeps giving the same expired TXT to add.
If you have the builder profile in a state of “verify your identity” and you already have a showing, you’ll need to start all over.

Here’s what you can do:

On your marks

  1. Enter the website selector.
  2. Delete all the domains.
  3. You only need one domain name.
    It says “verifying ownership of A public domain name.” Any url you provide will be the destination of user clicks. The root domain is currently shown.
  4. (It could also need to be the domain of actions in the future)

Get set

  1. don’t have a non-supported country TLD;
  2. To ensure future checks pass, have a site that responds with pages.
  3. get your DNS zone editor on your name server ready to add new TXT record. You’ll add one to your main domain and the subdomain you specify (even www).


  • add domain again to get a new challenge string, leave page open.
  • Add txt to DNS (I added to both top level and subdomain)
  • and give ~30 minutes (test the update has propagated, below).
  • press OpenAI’s “check” to have the lookup performed.

You can ensure before pressing “check”

When you add the TXT with the challenge string, you also can add another subdomain (not all hosting may let you add this without more setup or have direct DNS access). For a fictional subdomain:

  1. Add A CNAME redirect to a or an A record IP address.
  2. Save both TXT records from OpenAI and the new subdomain when you get the token from OpenAI
  3. After some wait, do nslookup to use Cloudflare’s DNS server to look up subdomain.
  4. when the subdomain is resolved to an IP address, the TXT also should be available.
1 Like

I have the same Bulider profile with you? and I could not public to Everyone. Have you deal with the problem? Thank you very much?

Thanks! I put in www. and it said verified, but the selector wasn’t working until I re-did without the www.