Why are none of my Canadian credit cards being accepted to charge up the API?

I have tried multiple Canadian credit cards, a travellers (prepaid) card, a virtual Netcoins card, and a traditional Mastercard, all with at least $25 available, specifying $20 initial charge and refresh when balance drops below $5.

All were refused by the OpenAI web service when I attempted to charge up my account so I could try some video subtitle translation services through GPT-3.5 API (for the first time)

Am I missing something obvious here?

PS. I also sent an email to OpenAI support, but lately they have been taking months to respond, which is why I also posted here.

PPS. I am a ChatGPT Plus subscriber and OpenAI doesn’t have any problems charging my card for this service !?!?

Welcome to the community!

Hello, try to turn off any VPNs you may have on. Contact your Financial institution and ask if they were the ones declining. Wait a day and try again, this has worked for other Canadian users. Otherwise, contacting support at help.openai.com or support@openai.com will be your best plan to fix this error.

In an account’s billing preferences, you can ensure that all information is filled out and matches your card.

I checked with my bank and they have seen no attempt to draw from my credit card, which has ample balance. Despite me being a Canadian citizen, and Canada being on the OpenAI list of supported countries, I am consistently refused on multiple machines, with or without VPN, with or without incognito/private mode, day after day.

I now have a potential client offering a contract to me that I cannot take because I do not have OpenAI API access. The slow OpenAI response is now impacting my ability to work. The last email I sent took them an entire month to respond to !?!? The crazy thing is that I’m already paying for ChatGPT services so the left hand is taking money and the right hand is slapping me.

I can’t explain why, but my traditional Canadian credit card just started working. Either the company fixed an internal issue, or the fact that I put additional funds (over and above the expected API charges, since the card was near its limit) caused the transaction to go through. Still very mysterious.