When I log in to ChatGPT, I am prompted for a login failure and a message "something went wrong. please make sure your device's date and time are set properly"

i’m iphone user, i also suffering with this issue since months ago but still persisting. the shown "something went wrong. please make sure your device’s date and time are set properly. check that your internet connection is stable, then restart the app and try again. (code: 343366A2-4B12-4F74-A51E-8951DA9F2552, API.Device-checkError,2) .

anyone know the support number ? i really want call support to fix this issue. i have been paid for this service but not able to use, which is not acceptable.

1 Like

I changed my preferred language to English in the iPadOS settings. That made it work.

I had the same problem and tried everything discussed here. I actually gave up on chatgpt app and while there was a power outage and wifi is gone I switched to mobile data and tried to sign and surprisingly it worked !

same issue happend to my iphone while my vision pro, macbook, ipad all works as intended, I tried everything but still no luck

Same issue :disappointed:

1 Like

How is it even possible that this issue still hasn’t been fixed?!

2 Likes


I see I’m not the only one…
The app stopped working about a week ago. Browser login on phone still works.
I’ve tried all of the above suggestions.
…I’m a beta tester, maybe try stable release…?

Edit 1: Nope, still same error…Processing: 1000000423.jpg…
Edit 2: Turning off wifi and use mobile data works.

1 Like

Same as experienced by other user.


It’s been almost a month and my problem has not been solved. I have tried all the methods.

There’s no solution.
Android 13, Firefox as default browser.

I’m gonna to ask a partial refund and I suggest you to do the same.

OpenAI is not being transparent about the real issue. This is not a network error but a Play Integrity and SafetyNet issue, which is why it hasn’t been resolved. Essentially, your phone isn’t deemed trustworthy.

Here’s how to fix it:

  1. Pass SafetyNet and Play Integrity:

    • Ensure all your banking apps work on your phone. If they don’t, fix your phone until they do.
    • Once your banking apps are functioning, proceed to the next step.
  2. Clear Data on the ChatGPT App:

    • Disable any VPNs (usually not a major issue), then attempt to log in.
    • Sometimes, SafetyNet responses are cached for up to 24 hours, so you may need to wait and try again after this period.
    • Clear the ChatGPT app data before each attempt.

That’s all there is to it. There’s no magic involved. Your phone needs to pass SafetyNet and Play Integrity checks. Basic integrity passing is sufficient; strong integrity is not necessary.

I wasted a lot of time on this because OpenAI misled us, making us think this was a network or region error. It’s none of that. Try this it worked.

1 Like

the same issue on Macos. have no idea

Could you provide more details, please? don’t know how to do that on Mac.

Same error started yesterday for me - android app, trying to log in through google auth