When I log in to ChatGPT, I am prompted for a login failure and a message "something went wrong. please make sure your device's date and time are set properly"

I used the same method by updating my Google play store and reinstalled my chatgpt

thanks, I solved by your solution.

This is very frustrating.

I’m a Plus User an I get the same error “Please make sure your device’s date and time are set properly” etc. since Feb 17th 2024.

Tested on different ios devices, with WiFi, on cellular network, even with my google account as an alternative. Same issue. My login works on the desktop computer but not on the ios App.

OpenAI support was not helpful.

Any ideas?

1 Like

Apple User.

I found a solution for this.
I deleted the app completely off my device.
I restarted my device.
I downloaded the latest version.
Logged in.

Worked.

:white_check_mark: hope this helps!

Thanks Vinous,

I tried that already.

What I found out in the meantime, that I have the same problem on different ios devices (iphones and ipads). Only when I came across a iphone 11, it worked. Looks like it is device type related.

Immediately after successful login the app tries to carry out a health check on the device. Then, the error message pops up.

Reinstalling the app and restarting the device resolved the issue for me.

Note: As additional measures, I turned off iCloud Private Relay (in the iCloud settings) and Limit IP Address Tracking (in the wifi setting) although I don’t think those were any issue at all.

iOS 17.4 and the newest Version of the OpenAI app now works for me :nerd_face::+1:

Thanks,

I just updated my Iphone SE II. Unfortunately, that did not help. :face_exhaling:

I’m facing the same issue

Also having this problem - does anyone have any solutions that work?

Same issue. I have this error message pop up when I sign in to chatgpt through google. Been trying for months to fix it…

Alright, I have been without ChatGPT Voice Call for 2 weeks and I was going to be crazy. Finally I have found a solution which nobody knows at the moment.

If you really want to solve this problem for Android phones. I have one solution for ya.

First of all you need a different phone with root access. First of all install a version which works on your main phone. Then install the same version for your second phone and login on it. With Titanium Backup, backup the whole application. Restore the application DATA only to your main phone with Titanium Backup.

It will open and will work!!!

NOTE: Do not restore the app, otherwise it will not open and will crash instantly!

Here a FIX for Android:

  1. Clear the cache of Google play store.
  2. Install the last version of chatGPT.
  3. Clear the cache of chatGPT.
  4. GO to settings → apps → Google Play Store → uninstall updates
  5. open Google Play Store and Update it to the last version
  6. Open chatGPT… And :partying_face:

The problem is here :point_right: google play store

2 Likes

For anyone who is using Xiaomi or Redmi cellphone in PRC please try to update Google Play Store to 40.1.20(2024/05/14) in Xiaomi Store. Clicking update link in the Google Play Store settings will always prompt it is already the latest version even it is not.

For iPhone user, I tried this and it can solve the problem.

Reset All Settings:

  • Go to Settings.
  • Tap on General.
  • Scroll down and select Reset.
  • Choose Reset All Settings. This will not delete your data but will reset all settings to their defaults.

Credit: solution is suggested by ChatGPT

Before this I had tried many things e.g. restart device, remove and reinstall, reset network, but it’s not working. But Reset All Settings can fix my issue. Please be noted that some setting need to be set again e.g. WIFI, alarm, world clock, etc.

Hey Android user from this site. After installing different versions of the google play store, trying different login methods, clearing the store app data and chat multiple times and resetting the phone multiple times nothing helps.

Any ideas? I have a subscription and can’t use it, and wanted the omni model in voice mode to test…

Phone: POCO F1
Android 11

I’m trying to log in via Microsoft account.

I tried everything you suggested, even resetting my settings, nothing seem to fix the problem on my iOS device , It’s so frustrating , I just decided to give up nd delete the app definitely

The same error on Android. I tried everything - cleared the cache and data, updated Google Play, installed the old version, changed the time zone - nothing helped.
What else can I try?

I have this same problem but on my Mac, with the Mac app

1 Like

I solved my issues with the same error on Android by doing the following:

  1. Clearing cookies and cache in Google Chrome through the Chrome settings.

  2. Clearing the cache of the Google Chrome app in Android (App info).

  3. Clearing storage and cache of the Chat-GPT app in Android (App info).

  4. Changing the default browser from Chrome to Firefox in the Android system settings (Settings → Apps & Notifications → Advanced → Default Apps → Browser App).

I’m not sure which step did the trick since I didn’t check in between, but if I had to guess, I’d opt for the default browser setting.

I hope this helps some of you.