Domain verification not working despite DNS record propagation

I can’t verify my domain although the DNS record has propagated everywhere.

  1. First I had my domain already verified in my private ChatGPT account
  2. My team wanted to switch building GPTs in a different ChatGPT account so I deleted the domain verification in my private ChatGPT account
  3. I tried to verify the domain in the new ChatGPT account and added the DNS record to my domain.
  4. The domain still couldn’t be verified and after 24 hours the “Check” button in ChatGPT to verify the domain was gone and I had to add the domain again.
  5. When adding the domain I received a new DNS record which I added to my domain again.
  6. This record has propagated as checked with a DNS checker but ChatGPT still says “Your domain could not be verified. Make sure you’ve correctly set the TXT record above. DNS records may take up to 30 minutes to propagate.”

I tried this with Brave and Chrome.
Is this a bug?

Did you delete the domain from the original account? Maybe once it’s verified and set to an account, it’s flagged if another account tries to claim the domain?

1 Like

I’m having the same problem. Set the TXT record on Friday last week. Checked with my host to make sure there were no problems on their end. Still, today getting the red box with, “Your domain cannot be verified.” Any ideas?

Yes, I did delete the domain from the original account.
Could be that this is the problem. How can I report this bug to OpenAI? Unfortunately, the Help chat is blocked at the moment.

1 Like

Having the same issue! Curious to see if anyone else finds a solution; we’ve tried with both a Google domain and a Squarespace domain.

Do you have a screenshot of the DNS settings for the domain?

1 Like

Same problem :frowning:

Your domain could not be verified. Make sure you’ve correctly set the TXT record above. DNS records may take up to 30 minutes to propagate.

Okay, I looked again in the old account and saw that although I deleted my domain, it appeared again in the old account after some time.
So I added a random placeholder domain in the old account like example com that I would not verify and then deleted my correct domain from the old account.
After that, verification in the new account worked!

1 Like


I have a problem with a new domain that I have just registered :frowning:

Nope, not bug. The txt code given to the previously registered domain is different from the txt code of the domain you deleted and reinstalled. Check it out if you want. So, you should add the last DNS TXT record to your domain.

1 Like

I think the bug is that deleting an already verified domain doesn’t work properly. It appeared again after some time in the old account.

Did you manage to resolve?

I’m having the issue today - after team upgrade & merge. I can add new subdomains but my primary domain did not move over.

‘Your domain could not be verified: The domain ‘’ could not be verified because it is already verified by another organization.’

This! There was no any warnings that this could happen if you merge your accounts. Now my excisting domain is verified under closed Plus account, can’t access on it and nor can verify it into my Team account.

1 Like

Did anyone find a solution to this? I still get this problem, after many months. If I wait a few days, I get an error saying the token has expired (which would suggest it is reading it?). But when I create a new token and add it, I get the error saying:

Your domain could not be verified: The domain ‘…’ could not be verified. Please ensure a TXT record with value ‘openai-domain-verification=dv-…’ has been set in your DNS settings.

I’m using Cloudflare and use mxtoolbox_com to verify that the record is in place and readable.

Got a screenshot of the record set-up in DNS? Sounds like there’s an issue on that end?

Hi Paul,

Here is the screenshot from Cloudflare:

And verified from mxtoolbox_com:

Any suggestions?

I think it might be the subdomain? I recall them not being valid, but I could be wrong.

Can you test a root domain? Let us know.

I’m not sure that I understand. I’m not using a subdomain. It’s on g[…].nz. Could it be that it doesn’t like .nz?

Your domain name in the screenshot has…

I believe you need to verify…

I believe you just want @ there for the root…

Like so…



1 Like

Ahh, I see… thanks, I’m not used to manually setting up DNS txt records. I see I have to format it differently, using the name as the domain and the key as content:

Thanks for your help!

1 Like