Unable to verify domain for CustomGPT with NameCheap

Hi there

I am trying to verify my domain to publish a customGPT. I have done the following:

  • Added the domain (no https or www, just the domain) to my builder profile
  • Copied the provided verification string into my NameCheap DNS under a “TXT” record type, with the host “@”
  • Waited 2 days

When I try to ‘Check’ the verification, I always get the following error message:

“Your domain could not be verified: The domain [domain dot com] did not have any TXT records.”

For context, I have other TXT verifications for eg Google, DMARC, my ESP, all working fine.

I have read all of the solutions on the other similar community posts, and nothing seems to work.

  • unable-to-publish-my-custom-gpt-publicly-unable-to-verify-billing-details
  • unable-to-verify-domain-with-builder-profile
  • new-solution-found-for-how-to-verify-domain-on-profile
  • solved-how-to-verify-domain-on-profile

Thanks in advance!

Already have a Web site created?

My case was solved when I created my web site and put the OpenAI badges.

Instead of @, i wrote in the domain name. Theoretically it shouldn’t make a difference, but you never know.

Also, with cloudflare it was pretty much instant, so that’s another option you could explore if you want. Registered multiple that way.

One more thought: what TLD is it? I’m wondering if that could be an issue. .AI and .COM were instant registrations for me.

1 Like

@iris3dgames yes I already have a website, but it’s an out of the box site built by beehiiv for a blog, so don’t have the ability to add an HTML badge like that.

Also FWIW I’d be surprised if that was a requirement to get domain registration working?


Thank you for this @Diet - will try using the actual domain. All the other threads suggested using @ so I went with that originally.

I’d rather not migrate to another DNS if its possible haha, but thanks for the Cloudflare suggestion :pray:

It’s a .com domain

1 Like

Brand guidelines, Here Iinfo logos and Badges

.dev with CloudFlare was instantaneous for me.

You can check if your txt record is propagated using several online tools. Here’s one,

Look up your domain and verify what is there matches exactly what OpenAI has provided to you.

1 Like

You can check if your txt record has propagated without using online tools:

Microsoft Windows [Version 10.0.19045.3930]
(c) Microsoft Corporation. All rights reserved.

C:\Users\user>nslookup -q=txt openai.com
Server:  d.resolvers.level3.net

Non-authoritative answer:
openai.com      text =
openai.com      text =
openai.com      text =
        "v=spf1 include:_spf.google.com include:spf.protection.outlook.com -all"
openai.com      text =...

Instead of, substitute different public DNS servers such as = Cloudflare. Or omit for your own provider’s DNS.

Instead of openai.com, substitute your own domain or subdomain you provided for OpenAI verification.


Yes, of course.

I just thought since this was an online forum and presumably everyone reading this would be doing so in a web browser, that it would be easier to give a link to an online tool for checking a website’s txt record rather than giving a bunch of instructions about how to do it on a bunch of different platforms, including mobile where they might not have ready access to a terminal or a full suite of command-line tools and I would be compelled to try to find apps for both iOS and Android I’d be comfortable recommending.

But, yes, you are right—one can check a txt record without using a website.


@tomalder Did you solved this problem? I followed your instructions exactly, but I succeeded. Could there be an issue with the details, such as the copied txt being incorrect?

1 Like

I sorted it by using a subdomain!


This was able to verify instantly.

Then set up a URL redirect for that subdomain to point the customGPT backlink to my main website :slight_smile:

Thanks for the follow up!

1 Like