[Solved] Cannot verify a new domain in Team account

I’m using ChatGPT for Team, and I’m an admin of the team workspace.

On the builder profile setting, I tried to add my domain, but nothing happens. The POST request returns with 403 error and it says “Not authorized for account”.

I guess there are several bugs related to Team account, and it’s one of them. Since yesterday my public GPTs created in this account was inaccessible but this is solved by now. Builder name is shown as “Community Builder” yet, and I guess this is because my website is not verified yet.


I have yet to get it to work, try daily for a week and made multiple updates to dns using new keys .i can get past verification and then doesn’t allow By Website to slide on…See below for another thread

Like the rest of the features waiting for a solid and realiable release with end to end transparency for paid services.


Thx. Actually my issue is not verifying itself, but the UI doesn’t respond when click “submit” button from the beginning.

POST /backend-api/accounts/{account-id}/domains returns 403 with Not authorized for account.

So the problem seems little different.

Now I’m an owner instead of admin, and it starts to work.

OpenAI guys please show users what to do when there is an error…


Is it OK if a moderator closes this topic?

If ppl still can find this post, sure you can go ahead.
I’m new to this forum, so I don’t know what does it exactly mean by “close”.

Yes this post will be visible even when closed.

Even now it can be found with a Google search.