I can no longer select "Public" to publish my GPTs?!

I made a small change to my GPT and tried to publish to Public. The system won’t let me. The option is now greyed out for ALL of my GPTs??? The change was minor and even made the system instructions shorter. But it briefly flashed that the instructions were too long??!

This is very frustrating because I am promoting this particular GPT and iterating on it based on feedback/testing. So now it can’t be part of the GPT store?

Does anyone know what is happening?

1 Like

I’m starting to think this is a widespread issue that they are probably working on. Since yesterday evening I have been completely unable to publish any of my GPTs to “Public”. It worked fine and since last evening it doesn’t work at all. It still doesn’t work. OpenAI doesn’t seem super open perhaps about throwing out a “we’re working on it” line. So I spent a non-zero amount of time trying to figure out if I had done something wrong or missed something.

I just think they are working very hard on making some major changes to the GPTs system and are breaking things in the process sometimes. It would be very helpful though it they could communicate better about what they are doing and the problems this might manifest for GPT developers.


I am having a similar problem. It won’t save “Public” but the “Only Me” and “Anyone with a Link” options are still available. All other GPTs created are still Public but I’m hesitant to make any changes until this gets sorted out. This new GPT is probably the most complex but it’s not throwing any errors. I tried consolidating some strings and even reducing characters in both title and description to see if it would help… but nothing worked. Functionality-wise, it works just as intended in both the preview and published modes. Will continue to monitor and hope this gets fixed soon. Fingers crossed…


I am havig the same issue starting today. Not sure why, but it seems that it’s a wide spread issue.

1 Like

Looks to be. Seeing the same greyed out confirm button and the cancel emoji :no_entry_sign: when I hover over it

compared to the working confirm button on only me/anyone with a link


1 Like

Yes, I’m the same way. If I make any changes to my other GPTs I’ll have to save to “Anyone with a Link” to save my work. So I get a forced vacation from working on my existing GPTs. :smiling_face_with_tear:

@pgleamy i found something that may indicate a category settings update

let me know what you think

When I try to choose “PUBLIC”,
“This GPT may be appear in the GPT store coming soon” was shown. Perhaps, it’s a limitation of the “public” choice based on the GPT store related work.
“GPT store” will be opened in a short time, or it will resume with regulations revised.

All the GPTs I’ve made are off of the “public” option.

Same here. No public after making changes.

Not that I’m too bummed out. The gpt builder seems to think it can add any functionality even if way out of the builder’s capabilities.

Ask it to add gmail integration and it’s like “done bro”.

Same problem here. I verified my domain by adding the TXT record and it shows green as also my name. I can only choose sharing as for me or anyone with a link. The public option is disabled

same issue, is it for all users? May be they open after GPT store.

I am having the same issue as described here. Has anyone already found a solution?

Same here! Perhaps this is a sign the store is coming? :eyes:

1 Like

:bangbang: It appears to be working again now! Hopefully the interruption was to implement some decent upgrades. One would be to make the system message editing window larger than, what, 5 lines? Also, I hope one of the additions is API calls to your own GPTs. I don’t want others calling my GPTs, but I really want to be able to API into my own. :crossed_fingers:

You can already use the Assistants API to connect to a GPT! Though you’d need to recreate them to do this. Try logging in to the playgound.

1 Like

The assistant’s API is extremely expensive. I could use it, but $$$ :smiling_face_with_tear:

Is this the same issue:

Hi all. when I try to save my custom GPT, the Confirm is ‘greyed’(or should I say “light-greened” out. When I hover my mouse over the button I get a circle with a red cross through. You can see this happening in a video I recorded at 1:18:20 here: https(colon)//youtube(dot)com/live/RyGjHL6IB-I?si=bjc-hiF3Y0uRsKXN

I’ve had this happen several times, and randomly. I’ve tried to do this on multiple computers and get the same result.

NOTE: I have also added this query in the BugsReport in Discord Server as well.