Unable to set Custom GPT as public and unable to edit existing ones without avoiding to made them private

I’ve been able to setup Custom GPTs for months using all available privacy options: only me, link to share, public.

EDIT (for the 1st commenter): I am verified publisher with custom domain approved since months.

Since 2 days I cannot set public for my custom GPTs, also for existing ones.

In addition if I edit a public existing one the result will be to de-publish it (only me or link only options ara available while in the past all 3 options of course).

I have 10+ custom GPT tailored for my needs (and some of them are already published to everyone and used by others) and I cannot tune them now before the store launch due to this “bug”.

EDIT: Added screenshot for debugging purpose.

Hi. There’s been some updates to the backend ChatGPT functions and choices available, with the coming of the GPT store (where that setting can make GPTs available to all within the directory).

To make public, you’ll need to review your builder profile.

image

You’ll need to authenticate to a web domain’s DNS there, or have a company API account profile configured in the correct manner. To then have your publisher name appear.

Then, when editing and updating a GPT, there is an pencil icon next to “public” choice in the “update” menu also, where you may need to review the particular GPT settings before it can again be public.

I forgot to mention that I am already a verified GPT builder with custom domain approved and also enabled the support email feature. (I updated the post).

The part where your dialog, different than mine, says “Complete verification” means you have to perform those actions.

You must complete the verification process by placing a TXT record in a site’s DNS server.

Go into the website dropdown in your main builder profile under settings.

  • Delete all the domains.
  • Start the verification process again.
  • Place the new token string into your DNS zone record.
  • Wait 30 minutes or so for propagation.
  • Press “Check” to confirm the new authentication token.

Then revisit your GPTs and make public.

I also would wait until there is a different email method than publishing your account’s details to users.

I already validated in the past the custom domain in fact I have the validation stuff in place since months.
This because I opened this case :slight_smile:

Anyway the glitch fixed just by

uncheck and check again the custom domain checkbox :beers:

3 Likes

same issue ?

I managed to resolve the issue. I accessed my builder account settings, removed all references to authenticated domains, and repeated the process with a new TXT file to be stored on the server. I logged into my OpenAI account and added a payment card for the professional API, which I promptly deleted since I’m already subscribed to the personal GPT plan and don’t plan to use the API.

To verify your account and deploy your GPT, you need to complete two steps: either confirm a domain by adding a TXT record to the server or provide billing details. In my case, the verification only went through when I did both actions simultaneously. Now I can publish my GPT models.

I hope this explanation helps.