Error when purchasing credits by card: "too many requests, please slow down"

when i setting the payment method,
api response:
“error”: {
“message”: “You’re making too many requests, please slow down.”,
“type”: “invalid_request_error”,
“param”: null,
“code”: “rate_limit_exceeded”

  • Why? What do I need to do about it
1 Like

This seems to be a Stripe payment processing error and not an OpenAI issue, where are you getting this?

1 Like

I would guess you need to slow down.

Or OpenAI needs to slow down with their requests to their website backend, or their card provider even.

You can try a completely different web browser after waiting for a cooldown period (1 min, 5 min?) and ensure it’s not you.

1 Like

Same problem. I can’t even pay for API… Card declined and now this error. Why are there such annoying limitations?

1 Like

I got same error. I can’t add card to payment method.
I already subscribed to chatpgt-plus.
but I can’t add payment for api calls…
what is wrong with this payment…
Btw I’m from Serbia, using serbian credit card, and already used for subcription chatpgt-plus…

1 Like

Same with me. I have been subscribed to Plus for many months now without issues. i tried to add my card for API today, but I get the message “You’re making too many requests, please slow down.”

I’m using a Canadian credit card. Not sure if its related to that or not.


hello everyone, has someone found a solution for this? i´m having the same issue

Just tried a few times and seeing the same issue in Safari and Chrome using 2 different cards, with cooldown periods of longer than 5mins between tries.

Turning on a VPN solved it for me

Had same issue, used Chrome to go to the website and got asme red “You’re making too many requests, please slow down.” message. Turned on VPN and clicked submit one more time for good luck and it worked

1 Like

I have the same issue. I had a trial account from a while back, trying to add my credit card now and getting the “too many requests” error no matter what I do. Different browsers, different credit cards, different networks, …etc.

I am also getting the same error while setting up payment plan with credit card

Several reports here in just an hour or two - likely a problem with the payment processor service.

OpenAI perhaps didn’t anticipate their own payment processor load when they change a million users with a maximum billing frequency of once per month to a whole bunch that all want to put $5 in to sign up and refill and to get gpt-4 constantly through the month.

Get 1 mil developers to put in $5 … that’s $5,000,000 in the bank. Or during increasing demand, a quarter million a day.

What VPN are you using bro? I’m getting the same. Just subscribed to GPT Plus, and now I wanted to add $5 in credits to get access to GPT 4 API, but I get an error using the same card (that was already in their system for GPT3.5 API btw), and now I am getting, too many requests.

Just following up - this worked for me when I tried it again today.

1 Like

Doesn’t seem to be working for me. Getting the same issue and everyone else.

Same issue from two different openai accounts, trying to pay with CC.

After trying many many times on Chrome, I finally decided to try it on MS Edge and it took my card the first time! Try it on Edge!

1 Like

I opened a new card in bank that is official in europe, then it worked.
I don’t have problems with first bank on other sites with paying, but here it does not work…, so I opened another card and that helped to fix issue with billing.

Has this been resolved? I get this error now when setting up the credit card for billing.

I am having issues as well. Any other solutions? Tried different browsers, no good.