Your GPT’s name is restricted for public sharing

Your GPT’s name is restricted for public sharing. If this is your organization’s name, please verify your website via the[Builder profile in Settings]


I am getting this same error. I have a verified domain. I get this even if I enable my name and have a verified URL.

1 Like

Yeah it’s crazy I don’t understand

You haven’t been able to publish for over 8 hours? Wow.

I had trouble publishing changes to my existing custom GPT, so I tried going to private and moving it back to public again.

Ever since then I’m unable to publish to public (but can update just for me).

@checkfucom did you eventually get it to work? I have the same issue. I have a verified domain already from like last week, but it’s still saying I need a valid “privacy policy”

TLDR; I fixed the issue by changing the name of my GPT to be exactly the same as my verified domain name.

I faced this issue despite having my domain verified and the custom GPT working with the name “Virtual Application Security Architect - VASA.”
This issue arose when I tried to change my logo to a different image. When I tried to save the new logo, the error showed up. I am almost certain that the check to confirm that the name of the GPT is exactly the same as the domain verified was introduced recently.

Here is how it looks now:
The screenshot below shows how it looked initially.