Unable To Publish GPT To 'Everyone'

I made my GPT when GPTs first got released. It was set to public, but when I go to the page now it is set to only people with a link. When I click “Everyone” and publish the update, it says “Published!” hinting that it worked. But when I go to edit my GPT again, its still set to only people with the link.

My builder profile is verified with a website.

Uncheck and check again the checkbox at the left of your custom domain.


This worked for me.

1 Like

Does your GPT have an Action associated with it? If so, you’ll need to add a privacy policy.

1 Like

Mine doesn’t have an action.

I did have an issue earlier where after enabling the feedback option in my builder profile, it bugged out and acted as if I wasn’t verified. Had to enable and then disable the name part in my builder profile for that to go away. I’m going to hope it’s just server issues and not my profile getting bugged

I had an action, and the reason why it disabled for me because I had to verify and publish using my name (billing name), you can do this by clicking on your profile on bottom left, and then choose settings → builder profile, toggle on/off your name/domain

I finally got access to the GPT store and can confirm that my GPT is searchable publicly. No longer a problem


the builder profile solved it for me! that was the solution in my case!