Problem with adding custom domain when creating GPT


As you can see the DNS ‘TXT’ value isn’t populating.

I’m using firefox.

The solution is the failure comes from using ‘https://’ yoururl . io/, instead use just ‘yoururl . io’. The https bugs it out.

1 Like

I am also having an issue - my domain is - I set the txt record days ago - still getting errors - would love some screen shots of what they actual record should look like in DNS

me toooo,
not working with GoDaddy, fireflare

It depends a bit on who you use for your domain management.
Each company will have a slightly different web-interface for management of DNS records.

But essentially, you will add a new TXT record, or append to your pre-existing record, and add a new VALUE or some time referred to as DATA where that equals the unique identifier given to you by the OpenAI verification pop-up.

I cannot find the menu. Is this only for the GPT Store beta users? (FYI, I am a plus user and I can create custom GPTs.)

Builder profile is under “Settings (and beta)” within ChatGPT “user name menu”.

Oh, I found it @_j ; thank you!

For GoDaddy, after you found a key* from OpenAI, doing this worked for me (under Domain → Manage DNS → DNS → Add Record).

Type = Select TXT
Name = <leave blank>
Data = openai-domain-verification=<a long string of random characters>
TTL = leave default


*Open AI – Settings – Builder Profile – Verify New Domain – Enter domain name without www e.g. just