Philippines users We are unable to authenticate your payment method

I am from Philippines so hopefully Filipino users will find this topic and let me know if they experienced the same and suggest a solution.

It has been 4 days now since i am trying to pay for my subscription but to no avail. I tried everyday and heres what i did for the past 3 days.

1st day: i tried my 2 saved cards that i used to renew before as i have been a plus subscriber for 3 months now, these are debit cards and its saved via LEENKFORSTRIPE (sorry i cant use the 1st word), since i thought its just an isolated problem i tried it again the evening

2nd - 3rd day: been trying different cards another debit card that i use to buy online subscription and credit card that i use to buy on ecommerce websites but problem is still the same been trying for like 3 x a day.

and this time for the 4th day i read a topic in this community heres (sad i cant post website url even in the same website) i live on a country that has dynamic address i tried restarting my wife and laptop for 15 minutes did it for 5 times until i got the nearest city but still i the same problem so what i did is that i bought VPN nordvpn to be exact together with dedicated IP selecting the nearest state then restarted my pc but still have no luck.

[i cant upload]

Is anyone experiencing the same? its been like this since july 1, 2024 i need to renew my subscription. Chatgpt support is not helpful at all no reply from them since i contacted them.

omg i was able to renew my subscription the one on that is saved in stripe leenk. 4 days until it was resolved so maybe they had a problem but didnt announce. I knew i was right saved card info on leenk (spelled wrong remove the double ee to i cause it doesnt allow me to post this if its spelled correctly) all saved cards on leenk are good its just that sometimes its the payment method that has a problem and chatgpt support cant do anything with this kind of problem so if this happens to you and if you happen to be in the philippines the solution i think is to wait until its resolved just try and try your card that you have used before even if its debit card, im using gcash debit card and it took 4 days for me and i think i has something to do with our IP since its dynamic if you cant wait for 4 days try turning off your wifi for 12 minutes to refresh your IP and keep trying.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.