Not able to add VAT ID in billing - support team not responding

Hi,

I’m ChatGPT Plus customer living in Germany. I don’t see the option to add a VAT ID to my billing details. I’ve looked into these settings: My plan → Manage my subscription → Billing Information.

What has made the situation worse is that I’m not able to get any response from the OpenAI support team. Here are the different options I’ve tried,

  • Send a message through help.openai[DOT]com (no response, it has been 6 days, tried multiple times)
  • Send an email to ar@openai[DOT]com (no response, it has been 4 days)
  • Ping OpenAI on Twitter (no response)
  • Requested privacy@openai[DOT]com to forward my issue to someone in the support team because this was the only email I found. (no response)
  • Requested help through OpenAI Discord. (didn’t get much help there)

Sad to say that this is the worst customer support experience I ever had.

Please see the attached screenshots. (couldn’t attach more than 1)

1 Like

Have you tried adding your VAT to your account via platform.openai.com?

https://platform.openai.com/account/billing/preferences

It may help with new invoices but for old ones you have to wait for customer support…

Also, OpenAI has a subsidiary in Ireland, since you are located in the EU. Maybe you can reach someone there.

Ultimately, we cannot help with customer account and billing issues. Besides the situation being understandably annoying there’s only so much support anyone can offer here.

Thanks.
You are right. I was able to add the company VAT ID on that page, and hopefully, it will be present on the next invoice.

I will wait for the support response to regenerate the previous invoice.

1 Like

Thanks and good luck!

I would not get my hopes up too far though.
Reason is that the platform is for API users, which are business accounts according to OpenAI’s terms of service, while ChatGPT is treated like a private end customer account.

Another option going forward could be a Team subscription which is also aimed at small to medium so businesses.

1 Like

It did not work for this month’s invoice.

When you log in to “openai.com” it gives you 2 options: ChatGPT or API.
It seems those two are separate and the settings in those don’t not apply to the other one.

https://platform.openai.com/account/billing/preferences is only for API billing.

Hi!
The functionality to add a VAT number has been added to the ‘My Plan’ section of the ChatGPT UI.

https://help.openai.com/en/articles/9038389-how-do-i-update-my-account-s-billing-information-e-g-vat-id

Hope this helps.

Yes. I received a response from the support team last week. They have been asking me for more details about the issue. (though I still don’t see option to add VAT ID as per the shared article). Seems they are working on it. I’ll check with support.

1 Like

Hi! I’m having the same issue (with a Belgian VAT-number). Did you find a solution? Thank you :slight_smile:

I contacted support through the chat bot, and they reached back after a couple of weeks. They fixed it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.