Cannot set my tax id for the billing


I want to change my billing settings to include my tax id. I go to settings>billing>preferences page. Try to enter ‘Business Tax ID’, but since Turkey is not listed in the select box, I cannot enter my Tax ID. Can you add ‘Turkey’ to the list of countries please.

Hey, closing the loop here, we don’t currently have a VAT registered in Turkey which is why you don’t see the option to set your tax ID to Turkey.

1 Like

Hi @logankilpatrick , thanks for the reply. Is there anything I can help for you to have a VAT registered in Turkey?

I want my country to have equal opportunity to innovate using OpenAI capabilities.

@logankilpatrick I’m facing the same issue in Germany for my ChatGPT Plus subscription.
From ChatGPT I go to My plan → Manage my subscription → Billing Information, but there is no option for VAT ID.

Logan has left OpenAI, so he likely won’t be responding.
What you can try is to contact to reissue past invoices with the VAT ID.
Also, I would go the standard route and contact as well.

Otherwise, there is nothing we can do in this forum to help you resolve the issue.