Challenges in Making My GPT Public: Domain Verification done but still not working."

Hi, I’ve tried everything to publish my GPT publicly. I updated my name wherever required, deposited $5 into my OpenAI account to ensure my billing information was correct. However, it didn’t work. So, I switched to the “Domain Verification” option. I purchased a new domain, created a website (a blank page), and added a new TXT record in the DNS settings with the link provided by OpenAI. It worked! But now, although the domain verification is successful, I’m unable to switch the toggle button to activate the domain. It’s no longer grayed out, but it’s white, and I can’t activate it. Also, the “Public” option remains unchecked. Please help me, I just want to publish my GPT publicly.

I was having a similar problem making my GPT public. I do have a domain and my name is appearing. I was able to verify my domain ownership by choising TXT and only @ and imputing the OpenAI string. Both name and domain are green and active. I am still unable to make it public so I kept it as anyone with a link can use it. If I appeal I would not be able to access or edit my GPT or share it with anyone. There might be a glitch or it is possible that OpenAI only wants to keep it’s own GPTs as public until the GPT store is fully open.