Msft Start-Up Founders Credits for OpenAI gives me 500 error

When I attempt to redeem the $2500 in start-up credits afforded my business I get a black screen with: 500 ## Internal Server Error.

How should I proceed?

Review your credit balance is available in OpenAI:

https://platform.openai.com/settings/organization/billing/overview

Generate an API key in a “project” (an administrative group of rights).

https://platform.openai.com/api-keys

Ensure the API is working - talk to an AI via Playground.

https://platform.openai.com/playground/p/N7Rpi4ea7NV2zYoUqpxI30Vs?mode=chat

Use example code that won’t cause server errors. Here’s a basic request using Python after setting the environment variable OPENAI_API_KEY in your OS or .env

from openai import OpenAI
client = OpenAI()
system = [{"role": "system", "content": "You are HappyBot."}]
chat_history = []  # past user and assistant turns for AI memory
user = [{"role": "user", "content": "Are you fully operational?"}]
chat_completion = client.chat.completions.create(
  messages = system + chat_history + user,
  model="gpt-3.5-turbo",
  max_tokens=25, top_p=0.9,
  )
print(chat_completion.choices[0].message.content)

Whatever makes a “black screen” would be some other software you are trying to use, right?

1 Like

No that’s not the issue at all. When I go from the webpage at: foundershub.startups.microsoft … benefits/redeem/openai

And click,

that to redeem, I get the 500 error on the next page.


Here’s what it looks like on openai.com/{redemptionCodeHere}

That may be a page that was a casualty of the large revamp of the entire OpenAI site this last week.

A random URL gets a 404 as expected, so there’s something still there at whatever URL path and query string the link contains.

We can @tag OpenAI to fix the site. But the recent support of specific account issues here with grants and credits has been zero, so the first line of contact would be “help” in the account menu. messages: API->feedback about the site. Then you can separately follow a message path about your account billing to see if it can manually be added.

1 Like

Thank you so much! I will reach out to them. Didn’t realize they did a revamp although I noticed the change in URL. Will reach out ASAP

I am also facing the same issue, I am unable to redeem the credits, it always redirects to the 500 internal server error.

1 Like

My recommendation: Submit a support ticket on the founders hub portal. From my experience they are quick to respond (well below 24h) and they may have a direct technical contact within OpenAI who can fix the issue for good and/or provide the correct link.

1 Like

Thanks, planning to do this later today. Will update on whether I can get the credits. It’s important considering my product leans heavily on the API

2 Likes

Hello, did you get help? Did you manage to access the openAI platform to redeem the credits?

1 Like

Same here, I noticed it today. :frowning:

I’ve got the same problem. If anyone has a solution, please let me know.
Thank you

I am still facing the same issue, i tried contacting both Microsoft startup hub support and also open ai support. nothing seems to work right now. Please let me know if someone finds an alternative way

Any results with this? Its quite unfortunate not to be able to use the credits awarded.

I have been so busy with app development I haven’t gotten a chance to contact them. Has anyone heard back from them?

I have contacted them using the chat option and they have got back to me . so I suggest you all to raise a request on open ai support chat with all the proof’s that you have been given the credit and they will reach out to you.

2 Likes

The solution is to message the chatbot on https://help.openai.com/en/ and give it evidence. It will credit you automatically.

1 Like