I am unable to access my custom GPT, the editor page shows a blank screen

I was working on a custom GPT and when I updated the instructions it suddenly went blank and now I see a empty editor screen and two errors in the JS console.

GET https://chat.openai.com/backend-api/gizmos/g-1KTUy8g1n?draft=true 404 (Not Found)
API error https://chat.openai.com/backend-api/gizmos/g-1KTUy8g1n?draft=true No config for gizmo

I am not sure what these errors mean but I am guessing this is something internal. I tried logging out and logging in again but that didn’t work.

The custom GPT seems to work correctly if I interact with it but I am not able to access the editor. What is causing this issue? Here is a screenshot of the errors.

1 Like

Welcome to the forum.

That’s a weird one. You might need to reach out to help.openai.com… Let them know browser, OS, and as many details as you can.

Good luck.

I had the same error. I posted a detailed bug report to the OpenAI Help Center, but I don’t think any humans actually saw it. After a few weeks I finally got a response, but it asked me to clear cookies/cache and share a screenshot. My bug report said that I did that and had screenshots.

Anyway, I had to make a whole new GPT. Hopefully it doesn’t happen again.

Suggestions: be sure to save your GPT’s prompt in version control, and don’t distribute your GPT’s url. Instead, get a custom domain and redirect to your GPT. That way, you can delete and remake your GPT without too much disruption to your users.

1 Like

I encountered the same problem. Approximately two weeks later, the problem resolved itself and I was able to use the editor function again.

TLDR; The GPT as well as the GPT Editor works now.

So a couple of things happened after I posted this issue. While the editor didn’t work, the GPT itself was working. But after a while I started getting a GPT inaccessible or not found error multiple times. Tried clearing cache and logging out but nothing worked.

I tried going to My GPTs and the custom GPT wasn’t even there. Going to the editor page directly did work, but every time I tried saving the GPT it errored. Thought I lost the GPT and was planning to redo everything.

I assume all of this was some sort of upgrade that was causing this because I was getting weird errors in the JS Console.

Left it idle for a bit and then suddenly everything started working correctly, including the editor.

1 Like

Same issue yesteday, had to create again. Old disappeared gpts were there all togheter, something happened but i created it again to be sure to have a fresh new one GPT

Do we need to get a subscription for editor access (I mean creating custom GPTs)? Or free version should be enough?

Check this post: