doesn't work and nothing else seems to either

I tried using API as I saw free credit, didn’t see the expired tag that was on it until after I got the error, tried to add credit, got an error saying it couldn’t process the request after I went through to add.

It said to go to but that site doesn’t work … at all… it doesn’t seem to carry over the login, and doesn’t even seem to have a button of any kind to login directly on it… and it mentions that I need to click a “help” button on the page concerning contacting support, but there is no such “help” button there.

There is a help button on but it just launches a really terrible bot, at least for this problem, as it didn’t have an option about issues with payment for API.

Initial error:

Oh, also tried with 2 different browsers to rule that out.

Here’s a more reliable path for others to get the help assistant to pop up, which is normally in the lower right of the help site, but only works reliably in Edge. It seems you got there.

  2. in the left sidebar, near the bottom (you may have to hover a mouse), click “help”
  3. the help widget appears
  4. in messages, you click through a ‘phone tree’ of options and diversions until you are at a point of sending a message
  5. you send a message to an outsourced contractor that has little to do with fixing the backend payment problem affecting a wide swath of API users right now.