GPT'S : Website Toggle box issue


I recently developed a GPT and I’m eager to test the signature feature once it’s released. The toggle switch button for my name works correctly, but the one for displaying my website isn’t functioning (the toggle switch refuses to activate).


Has anyone else encountered this issue? Does anyone have a solution?

Note: I’ve had my site verified with DNS and it’s checked, so the problem isn’t coming from there.

1 Like

did you ever get this fixed? I’m having the same issue. I verified my website, made my GPT public but cannot toggle the website to on.

Yes it is fixed.
Actually, I thought my website was verified because I had the little v close to my domain but I reality it wasn’t.

I finally add both domains:

One with
And another one with

And it was fixed.

i am having the same issue. aren’t those two urls identical? maybe i am missing something.

1 Like

Sorry I made a typo
One with www, one without.

I think i might have found the solution…

I also had the problem, at first i thought it could’ve been related to GPTs assigned names as my first GPT is called Prompt Engine and there was another called with the same exact name… but it wasn’t the case.

The problem seems related to the prefix of the domain you enter and try to verify. I believe at the moment it doesn’t support the (www.) world wide web prefix. In fact if you take a closer look at the “example” OpenAi provides in the field box (when you try to add a website) it only contains “”. I didn’t notice at first, only after several times removing and re-adding the domain.

The first time i added my domain as “” instead of “” , and added the TXT record as @ in the DNS with the OpenAi key, everything worked perfectly and i was able to verify the domain and toggle visibility.

In short, just use your-domain. your-extension without the www. prefix and it should work. I advise you to remove the previously www. verified domain in any case. I hope this also works for you.

I am still having this issue, despite having verified my domain name without the www.

I’ve tried deleting and re-adding it a few times and no luck.