GPTs Bug - User reporting GPT can't talk to Action

Hello, my team develops ResearchGPT:

ResearchGPT allows users to search and analyze research papers in our academic search engine, Consensus. I configured an Action that uses our Search endpoint for this.

One of our users is reporting that every time they use the GPT, they get the following error: “! Error talking to”

I cannot reproduce this. Can anyone else reproduce this issue? Anyone know what might be going on?


I’m one of your user, yes, i reproduced this

On my computer, it is win10 ltsc, checked with Chrome, Edge, and Firefox, they are the same

Then my friend use another GPT4 account, but in ubuntu 20.0.4, with firefox. He can play the same prompt as i put.

He mentioned one thing: the first time he run research gpt, he says it asks him to authorize something, then he clicked ‘always allow’.

But in my situation, i haven’t seen this.

Hope it can helps, if need more detail just replay me, thanks for your product, it helps us a lot

Huh, i actually solved this

In the GUI, it need users to set privacy

By default, it is ‘ask’, now I switch to always allow then fixed.

well, if u can see this message, maybe u can add this to user guide, or anyhow

hope helps :slight_smile:

same question.
Even if you click always agree, it doesn’t work.

1 Like

Same issue here.
From today morning I get the message “The requested action requires approval” on all actions calls.
With @Yongzhao solution I solved for myself but it’s a huge problem for other users.


Me too! Worked without issue yesterday, but using Always Allow or Ask both gives me the following response since this morning. Not great when demo’ing stuff to potential clients.

The response in debug mode looks like this, an no backend call is actually made according to our logs:

  "function_name": "<ACTION NAME>",
  "domain": "<MY DOMAIN>",
  "message": "The requested action requires approval",
  "action_id": "g-<A LONG ID>"
1 Like

Same problem, changing privacy settings to “always allow” to the domain configured in action doesn’t help. Attempted log out / log in as suggested earlier in thread. Sometimes the issue presents itself as “TypeError” when conversing with the GPT.

This seems to be fixed on my end. Are others seeing the same?

1 Like

yuh, finally fixed :grinning:
back to work eh

Issue still persists.
I am developing a GPT and since yesterday my GPT is not triggering any actions.

It was saying the same “The requested action requires approval”. Now it doesn’t even output these logs anymore.

Looking at the API logs - I can see that endpoints weren’t even called by the GPT. It seems like some internal GPT issue with permissions. It is neither asking user to allow action to be triggered nor it is giving it internally, so it is unclear which permission it requires for action to be successfully called.

It does work now, though I noticed that the flow always starts with “Error talking to…” error, and after this providing some “let me fix it” message successfully fetches the data from my server.

Hmm… Is it because my configuration bad or OpenAi’s way to seamlessly deplete my request quota? :smile:

It would be nice to have a clue about the way to debug the issue with my requests, if it is on my side…

Have you tried entirely deleting and recreate the action and then publish ? I noticed it helps to get action updated on the OpenAI side sometimes

No, previously I tried just minor updates of both schema and GPT description in order to re-upload the GPT.
But according to your advice I deleted the action and re-created it. That fixed the issue for me. Thank you!

The issue seems to still persists.
Created an action, and it works for about 10–15 calls after that it fails without even making a request to my service, really frustrating, when asking what’s wrong I only get ClientResponseError as an answer and GPT can’t even tell more about the error.

Switching from “ask” to “always allow” back and forth sometimes fixes it for some time, also re-creating it fixes it for some time.

I also waited a couple of hours after it starting to fail to see if it’s just a temporary issue, but no luck.

Really inconvenient when trying to create a GPT with some custom capabilities.
At some point, I also re-read the TOS to see if I’m violating any, and they might be just blocking me, but nothing points out to be in any violation.
Is there a limit to how often an action can be called?
For my GPT idea, it needs to frequently talk to my API and those making sometimes up to 15 requests for one prompt, depending on how demanding it is.

having a similar “intermittent” error with :ClientResponseError
where when error: GPT doesn’t appear to actually make call…
no idea how to debug when the error is hidden who knows where;
this is started to get frustrating; maddeningly unreliable…