None of my Custom GPTs that use APIs is working, since around this morning

I have a number of Custom GPTs that access APIs, they were all working this morning (around 12 hours ago, when I last accessed them) and now none of them is working.

In the debug mode, I get: “message”: “The requested action requires approval”

That is correct, but the approval button no longer pops up for me to click. So the API call just fails. I have tested my APIs with Postman and they all work fine. It appears to be something in the authentication process within ChatGPT.

Anyone else having this issue?


Having the same issue here, don’t have a clue how to fix it, is that OpenAI’s problem?

1 Like

Same. I kept trying back ups of my schema thinkings I messed something up. But my server is running fine and the debug looks like the requests are not making it past an internal authentication on the openai side of things. I’m going to say it’s something on OpenAI’s side.

1 Like

I am also facing the same issue. It was working fine about 6 hours ago, but then it stopped working and I have tried several things but to no avail. Considering that the ChatGPT Plugin installed on the same domain is functioning normally, it seems like this is a problem with the GPTs

1 Like

Yes I am seeing this to… my external api calls were working fine this morning and now this evening they do not work because it cannot pop up the permission button anymore.

1 Like

The same. I thought the problem was in my schema. I did everything I could to fix it… Literally 3-4 hours ago, requests went through, but sometimes there was an error.

1 Like

Same here with my actions. It’s not working when I make any API calls, and I keep getting an error message that says ‘The requested action requires approval’. Also, when I try to adjust the privacy settings for my GPT, it only shows the domain names instead of the specific calls. I think this is a good approach for a better user experience, as it’s simpler to trust a domain rather than managing each call separately. But I’ve noticed that even after I allow access, the calls sometimes work and then stop again. Plus, every time I update my GPT, I have to reset these permissions, which seems unnecessary if the API schema hasn’t changed.

Another issue I’m facing is that the action calls are quite slow. Speed is super important, especially for GPTs with actions – they have the potential to be really successful if everything runs smoothly. Waiting for a response isn’t a great user experience. It would be awesome if this could be improved!


OK, SO I am not going crazy and I don’t need to take this personally.

From what I know, there is normally a popup requesting the user approves the API call or can set the approval to default yes, approved. I don’t see this popup at all. I think this is the reason why.

Either way, this aint my fault, just got to waiter for OpenAI to pull their finger out and sort it.


Btw yes. Yesterday the popup came out, but today it doesn’t

1 Like

I have tried a few different flavors of “is_consequential: true”, but it always calls it ““is_consequential”: false,”. Its all I could find in the Docs that references this issue.

“” [

Consequential flag


In the OpenAPI specification, you can now set certain endpoints as “consequential” as shown below:

  operationId: blah
  x-openai-isConsequential: false
  operationId: blah2
  x-openai-isConsequential: true
  • If the x-openai-isConsequential field is true, we treat the operation as “must always prompt the user for confirmation before running” and don’t show an “always allow” button (both are new features of GPTs designed to give users more control).
  • If the x-openai-isConsequential field is false, we show the “always allow button”.
  • If the field isn’t present, we default all GET operations to false and all other operations to true""

Does anyone know if GET operations that used to be flagged is consequential: true happened to be called true. I cant get that to happen now

Just checked, it’s all working now!

What’s irritating is that I messed up perfectly good code (which is now fixed again) trying to resolve an issue that wasn’t my issue!

1 Like

I feel your pain man, I was pulling an all-nighter the day before to fix it for a demo.
Went to sleep when it worked, woke up … thought I was crazy

I see the plugin loading button when working with my GPT


And the request don’t seem to work.

Is this just me ?