(GPT development) Unable to save OpenAPI spec

When I’m using the new OpenAPI spec editor I’m unable to save updated versions of the spec after adding new endpoints. Or at least it’s incredibly flaky.

Anyone familiar with how to do this properly?

Steps I tried:

  1. Configure GPT
  2. Update OpenAPI spec and see new actions populate below
  3. Click back to configure (I also tried just staying on this page too)
  4. Click update and confirm (which says it successfully completed with a link to the GPT)

After these steps I go back to the GPT and try and use the endpoints and they don’t work. (I’ll also note that not being able to see the actions run makes it really hard to debug what’s happening with a GPT) Also when going back to edit the API spec, I can see it didn’t save.

Super frustrating end to a dev cycle when creating new capabilities for a GPT.

I came to the conclusion you have to delete and recreate the Action spec each time you want to modify them. Then it works.

2 Likes

Ah I didn’t think of that. Good idea. I’ll try that.

*** Confirmed this works!

That’s a helpful work-a-round for the bug. Thank you for sharing.

I would prefer not to have to recreate the OAuth config every time I make a change so I’m looking forward to a fix.