Getting 404 error when trying to publish my GPT to the store

I’ve built my first GPT and want to publish it to the store. I’ve made it public, verified my domain, submitted a link to it in the GPT store and got a Submit successful response. The pop-up said that my GPT will be listed within 5 to 10 minutes and gave me a store URL for my GPT. However the store link returns 404 error and it’s been many hours since I’ve submitted it. I’ve tried resubmitting it multiple times and get the same 404 error and the store doesn’t index my GPT as well.

Am i doing something wrong?

1 Like

There is no official GPT Store at this time from OpenAI

1 Like

I’m getting 404 errors trying to share mine as well. It gives anyone that tries to access it the 404 message or this…

Were you able to solve the problem?

1 Like

Did you try to put your gpts public. In setting you can click on 3 options in gpts.

I set it to public and then used the link it generated after. I don’t have my own website though for the privacy policy. Could that be the issue?

1 Like

To make it easier for you, I’ve provided a step-by-step guide below and attached screenshots for reference. Let me know if it did help.



1 Like

Thanks for sending that over. Thats where I have been sourcing the link from, it just seems to not want to re-direct from the Reddit posts I have put up. Very strange. The only thing I think it could be is I dont have a link to a privacy policy, but I haven’t been using any actions so I shouldn’t need one?

1 Like

Please create another GPTs agent and test the links. Recently, there have been some irregularities with link functionality, possibly due to the impending launch of the OpenAI store, which may be influencing how these features are managed.

I’m getting constant “Error Saving GPT” errors. I’ve searched the forum but most people say its because of the 10 File limit. I have 2 GPTs and one only has 9 and the other has none. Ive been adding a lot of Actions though, around 6 or 7. Sometimes I go into the GPT that has all the actions to make some changes and the actions are duplicated, thats when I know I’m getting the error as soon as I try and save it. The only way around this is deleting all the actions and then it lets me save it.

You should be aware that GPTs are currently in beta mode, so encountering such problems is expected. These issues will improve over time. Patience is necessary as the system evolves

I gave this a shot but I think your right. It could be a BETA issue. The GPT is also pretty maxed out on the instructions side of things too. That could always be it, at least I know there are others dealing with similar issues.

Any other tricks you have tried?

How much files do you have ? 10 max

I only put four in the knowledge base

I have been dealing with the same thing since the store opened. The link takes me to a 404 dead page. My gpt is named Heart-Sync.
Thanks,