Gboard Acting Up In ChatGPT Android App

When I use the ChatGPT app on my android device, the keyboard messes up. Some strokes don’t get inputted or don’t registered at all. Meaning you will either see that the keyboard shows that you pressed a button but doesn’t input it in the text field, or the keyboard doesn’t even realize that you pressed something. It also randomly jumps to caps lock which also causes strokes to go unread.

The caps lock thing in particular messes with the autocorrect by cancelling it/causing it to go ignored. The autocorrect is also affected by space strokes going unread. The result is a horrible typing experience as this glitchy behavior messes up whatever the user is typing.

This ONLY seems to be occurring in the ChatGPT app. I have tried other apps and the keyboard works fine. This happens regardless of typing speed.

Here is a video demonstrating this

I am using a Pixel 7, Android 14 May 5 2024.
ChatGPT app version 1.2024.151


Mine is doing the same, but only since yesterday, I uninstalled and reinstalled it and still the same. Very strange and quiet annoying.


Seems to also happen when holding down a key. Fill the textfield with text. Now hold down the delete/backspace button without letting go. You’ll notice that the caps lock thing happens which cancels the backspace from working.


Same thing for me, started recently

1 Like

Nice catch! Yeah I see the issue now. It just jumps immediately.

I am NOT letting go of the backspace button.

It looks like it loses focus and then re-focuses rapidly. Ruining the flow.


Same here - Pixel 8 Pro. It’s been happening for 1 or 2 weeks now. The app is almost unusable.

My keyboard types and dictates fine in other apps, but in the chat GPT app, both are super broken. When I type, caps lock is flipping on and off all the time, and the wrong keys get pressed. If dictating, it gets interrupted every one or two words.

Rebooting the phone didn’t help.

ChatGPT v 1.2024.151.

EDIT: I also tried toggling both the background conversations and haptic feedback options off/on/off, and everything is still broken.

SOLVED: I updated the app to 1.2024.157 and the issue is now fixed!


Another issue:

The wakelock doesn’t work anymore. My phone sleeps and the voicechat is dismissed. Bruh

They completely borked the app. To be fair I’m in the beta program so not too mad. Am wondering if everyone else is also in the beta program

Edit: Nevermind. They had a broken permission pop-up that I had to accept. Weird. It never showed up before and was only shown after a couple attempts and in the middle of the conversation.


Can you elaborate a little bit on the solution. I have similar albeit less annoying issues on my Samsung device.

1 Like

The mobile website is broken as well. Doesn’t appear to be as bad as (I think) it only happens near the start of the input. But opening up a web browser to avoid the broken app isn’t a sufficient workaround.

1 Like

For the app closing?

I honestly have no proper steps. I was driving and the conversation cut for the third time. On this time I notice randomly in the conversation text that it threw me back to there was a transparent box asking for permissions.

After looking through the settings I found this

I’m not sure if it for some reason toggled off as this was never an issue before. But yeah


I am having the same issue. This is occuring since last 1-2 days. Not facing this in other apps. I am a Chatgpt plus user, I have to reconsider my subscription if it remains unsolved.


Thanks for sharing.
I will have to dig deeper on my end to figure out what is causing this backspace issue.

1 Like

Same for me too, makes the app unusable… on Xiaomi 12 Pro

1 Like

I’m having the same problem. And it’s unusable unless you type really slow.
I’m using Xiaomi Redmi Note 10 Pro

1 Like

Same issue on OnePlus 8T, noticed it for the first time today.

1 Like

Same issue using redmi note 4

1 Like

Same issue S21+ happening for a few days now. Typing anything takes 5x longer than it should. It’s practically unusable.

1 Like

Same issue. Super frustrating and only started happening recently, I’d say in the last week or so. I can’t use the app anymore, way too difficult to type anything.

Device is a Redmi Note 10 Pro

1 Like

Same issue moto g34. Sad implementation error by the developers. Please fix quickly.

1 Like

Same issue here on Pixel 8 Pro. I think it started to happen after I updated Android to AP1A.240505.005 build.
Also I am 99% sure this happened before and resolved itself through some update. But I don’t remember if it was an Android update or ChatGPT app update.

Definitely only happens in the ChatGPT app though.

1 Like