For those of you who have trouble to verify your domain, try this

First off I didn’t expect this to be a problem at all when I first signed up my builder’s profile. However, when I tried to publish my GPT to Everyone, I was only given the option to Publish to either Only me or Anyone with a link. Publish to Everyone was greyed out because my builder’s profile was not verified.

Step 1: find your builder’s profile

In order to do that, you can access Builder profile setting either by clicking the little pencil next to your profile picture


Or go to your ChatGPT Home page and click on the GPT profile icon at the bottom left → Settings → Builder profile. Either way will take you to the correct setting page for our next step.


Step 2: verify your builder’s profile

Two ways to get this done. You can choose to verify with your Billing name or verify with your Domain (personal website)

To verify with you name -

Go to My Plan


→ Manage my subscription

Now you should see Payment method, Billing Information, and Inoivce history on the page. For those of you who want to publish with your own name. This is where it is being captured.

However I believe many of you were not brought here for this as it’s fairly straightforward and not the problem of majority. What I had been trying to find out, but had a difficult time finding out, was actually how to verify my personal website. After reading some of the posts I have come to realize that the most popular reason for not being to toggle on is that they don’t own a domain!! :smile:

So first please ensure you own a domain that is being hosted somewhere and has a web server where you can point to.

What’s the correct way of veriying a domain? First off, you have to know that this issue is not uncommon and people spend days (like me :frowning: ) until some magical moment so bear with me for 2 mins of your time, this may save you a few hours before jumping off the boat!

Now assume you are already in Builder profile settings. Go in Links → Verify your domain. Add your domain, i.e. www xyzabc com → Verify → Copy and paste your TXT record


Go to your host server → Manage DNS record → Type: TXT → Points to: the TXT record you just copied → Add record.

Go back to your Builder profle setting → Verify new domain → Add a new domain → Enter xyzabc com → Submit → Repeat the TXT part.


So by now you should have two domains added in your Links. One is www xyzabc com and another one without www.

Keep in mind what’s important here is NOT that you verified both www xyzabc com and xyzabc com verified. What’s important is the sequence of adding your domains! The toggle thing did NOT work for me after I first only verified my xyzabc com. So please make sure you verify www xyzabc com before xyzabc com. This is super important!

Once you get both of them verified in correct irder, you should be able to toggle it on or off like the one besides name. From there you will be able to Publish to Everyone.

Hopefully this helps!

1 Like