Issue Completing Builder Profile

I created a couple of GPTs and wanted to get things in order to be able to leverage the store when it opens. When I go to Settings/Builder Profile it says this…

Complete verification to publish GPTs to everyone.
Verify your identity by adding billing details or verifying ownership of a public domain name.

I don’t have a domain I want to submit. So it makes it seem like I can add billing details instead. Where do I do this? Can’t seem to figure it out. Any help is appreciated.

1 Like

I just ran into this even though I had a domain verified.

I unchecked the verified domain then checked it again, and it was okay. So, maybe try doing the same with the Name?

1 Like

I got the same problem. Wait for the solution.

1 Like

I have the same problem. Can’t verify. I subscribed to ChatGPT via iPhone. On the Web, I don’t have the option to activate the “name” button. I don’t have a domain.
I have filled in payment information on OpenAI (for Playground), but nothing happens…
Any ideas?

No idea. Haven’t figured it out. If you find a solution let me know.