File upload not working? Data Analysis ChatGPT 4 update

Is data analysis broken for anyone else since yesterdays update? It’s not working for me in either the main GPT4 window or it’s own Data Analysis space. It just doesn’t see or can’t access the uploaded files.

Is this just happening for me or everyone?


I have the same issue, after update on 6 Nov 2023, Dall e, data science, uploading file all not working till now. it apparently the new update has not been fully assured workability before release.


to give further updates, this issue is persist on browser, but the function works on my ios apps, felt a bit funny, but don’t why this happened.

1 Like

Same. Upload button in the GPT config does nothing. You can upload it as a user of the gpt at run time but that makes no
Sense if it’s a knowledgebase

I am not able to add any .docx into knowledge for the last couple of days. The files are pretty small in size. I am getting “error uploading” and “unable to extract text”. I have also tried it on chrome and firefox. This is on a windows desktop.

What in the heck is going on? I was able to load 2 .docx’s in the last 2 days then it just stopped. I have tried clearing browser cache, relaunching session. etc.


well … i just started using this thing yesterday and results have been totally crappy…

1 Like

I made a gpt with some pfds and its not working. yes they have been uploaded but the gpt does not work… maybe its the same issue?

1 Like

I had the same problem too

Same issue here. Please, if anyone knows a workaround on this, please share. Thanks.

Today Data Analysis can’t get results, even in the main all-in-one model:


Same issue here.

Me: many users are reporting issues with uploaded files not being accessible. what is going on?

GPT: I apologize for the inconvenience you’re experiencing. There seems to be an ongoing issue with accessing and executing uploaded files. This could be due to a temporary technical glitch or a limitation in the current system setup.

While I can’t provide a specific reason or solution for this problem at the moment, rest assured that user feedback about such issues is valuable and typically addressed by the technical team responsible for maintaining and updating the system. In the meantime, I’m here to assist with any other queries or activities that don’t require file uploads. Please feel free to ask anything else!

I can confirm the issue, and this is affecting also the dowload of files generated within the python sandbox. It seems the model has issues accessing the output streams or any file from the python sandbox environment.
An example answer follows:

# Attempting to write "Hello World" to a text file within a try...except block
# to capture and display details of any exception that might occur

file_path = '/mnt/data/hello_world.txt'

    with open(file_path, 'w') as file:
        file.write('Hello World')
    success = True
    exception_info = None
except Exception as e:
    success = False
    exception_info = e.__dict__

file_path if success else exception_info

It appears that the internal error occurred again, preventing the execution of the file-writing operation. Unfortunately, due to the nature of this exception, I am unable to capture and display its details using the standard Python exception handling methods.

Does OpenAI already know this? Where can we report? There’s no “report a bug” option in the settings.

edit: Thanks @Foxabilo I reached out just recently.

ChatGPT issues should be directed to and using the support bot in the bottom right corner, the developer forum is not the place for non API related support.

1 Like

It was working earlier, now it’s not working again. Idk why.

I have the same problem it was working today very well, it seems to be a general problem

Im facing the same issue since the last update.

Also the response times for both GPT-4 and GPT-3.5 have increased drastically.

1 Like

I am also experiencing issues. ChatGPT responses have been really slow and have been getting various errors (e.g. network errors) when using the data analysis.

Now the issue seems permanent, happening for every single request and data analysis.

Is anyone at OpenAI checking out this problem? Seems like the quality keeps getting worse every day. Adding a bunch of new stuff without testing it properly isn’t what we were hoping for from OpenAI.

1 Like

I’m having the same issue. I tried uploading .xlsx, .csv and .pdf and no results. It seems like it’s unable to access its previous functionalities since the last update. ChatGPT is effectively bricked right now until they fix this.