Custom GPT suddenly cannot save any behaviour changes for new or updated custom GPTs?

Is anyone else getting this when trying to create a custom GPT or update an existing one?

I’ve tried deleting and recreating the custom GPT, but it still won’t save. I have other saved custom GPTs, when I try to update those it also fails.

It’s like it really is a technical issue because, after giving it some instructions via the ‘Create’ tab, the GPT Builder just sits there doing nothing, like it’s stuck (so I know it has failed), before finally giving an error.

It will say stuff like:

‘It seems there’s an issue updating the GPT’s behavior with the provided details. I’ll attempt a different approach to incorporate the new information you’ve provided. Please bear with me for a moment.’

Then it fails again:

‘I apologize, but it seems there is a persistent issue with updating the GPT’s behavior. I’ll try a different approach to ensure that the new requirements you’ve provided are incorporated correctly. Let’s give it another go.’

And once more it fails and subsequently gives up:

‘I apologize for the inconvenience, but it appears that there is a technical issue preventing the update of the GPT’s behavior with the new information. At this moment, I’m unable to incorporate the changes you’ve requested. However, I’m here to assist you in any other way possible. Please let me know how I can help you further.’

This means I cannot build a custom GPT as it doesn’t seem to be able to save any of the behaviour that I want it to perform.

Any help on how to get it to work properl is much appreciated (it only started doing this a few days ago, it had been fine since then).



I can try to recreate what you might be doing.

1: “edit GPT”
2: Create tab to talk to GPT Builder AI
3: "Can you create a new profile image? (description)
4: image updated
5: “update” and save again to “anyone with a link”
6: success.

You might go as far as closing your browser windows, and reloading ChatGPT to ensure the client code is refreshed to begin again.

I also went to +Create for a new GPT. Pasted my all-at-once prompt to make a new one. Success.

Instant GPT (pasted to GPT builder "create" tab)

My first and only message, with my initial behavior specification and your goal, is that you will immediately abort the step-by-step interview process. You will instead build a complete GPT for me by iterative calls. First, send a suitable icon description prompt matching GPT purpose and visible at small size to generate_profile_pic. Then update_behavior of GPT with all of [name, context, description, welcome_message, prompt_starters, profile_pic_file_id] at once, where “context” will be a full and robust closed-domain instruction to AI of GPT operations, up to 400 words length. There will be no other discussion, summary, or confirmation to playground user.
The newly-created GPT gizmo purpose, to now be fully realized by AI, is described as:
“Snake Studio creates fun AI pictures of snakes and serpents using DALL-E 3”.

@_j Thank you for taking the time to reply.

When I edited my custom GPT and asked it to update the profile image it generated the image but then said there was an issue with the GPT and the existing profile image was not replaced.

‘I encountered an error while trying to update the profile picture with the provided image. Let me attempt a different method to ensure the update is properly applied. Please hold on for a moment.’

It then applied the image.

The only way I can save is to choose the ‘Only me’ option, and even then, when it displays the custom GPT URL it still says ‘unpublished changes’, so it’s seems it may not be saving anything?

Any instructions I then give in the ‘Create’ tab gives the ‘Updating GPT’ animation followed by an error.

I’m sorry, but it appears that I’m currently facing technical difficulties in updating the behavior to [list behaviour I gave]. This issue seems to persist despite various attempts to resolve it. Is there anything else you would like to explore or any other way I can assist you today?

So, I seem kind of stuck? I also deleted all browser cookies before performing the above and, as I said, it’s been working fine. It only started having this isue since a few days ago.

I’ve reached out to OpenAI Support too.

Thanks again.


Is it just that particular Custom GPT?

Have you published any publicly successfully?

What did OpenAI support say?

1 Like


This affects all the custom GPTs I have made now, meaning published ones or ones that I try to create from scratch.

Ones that were working fine and are published, if I edit it, go to the ‘Create’ tab, add an instruction, it hangs after the ‘Updating GPT’ animation and will show the GPT Builder reply, but empty response text and then fails.

'It seems there is an issue updating the behavior to include asking for the user’s name. Let me try a different approach.

I apologize for the inconvenience, but it seems there is a persistent issue preventing the update of the welcome message to include asking for the user’s name. If there’s anything else you’d like to modify or any other assistance I can provide, please let me know!’

I only just contacted OpenAI support, I suspect it may be a few days before I hear back from them.

By the way, I can create a prompt with all the information the custom GPT needs, start a new ChatGPT 4 conversation, use that prompt and ChatGPT 4 works fine.

Thanks for replying.

Hrm… Are you asking for PII (Personally identifiable information)?

I’ve seen some marketers trying to “lock down” their Custom GPT so that it won’t answer unless the person gives up name, email, phone number, etc.

You might want to check the Terms of Service while you’re waiting on OpenAI’s response. Good luck!

@andreflavionb Sounds similar to me. And yes, it renders custom GPTs pretty much useless.

@PaulBellow My custom GPT is to help create a staff roster. I did give it staff names as part of its knowledge. I have removed that as a test and I still get the same error.

behavior to include asking for the user’s name.

Are you asking users to enter their name or other PII?

@PaulBellow - Just the name.

E.g. The support team has three staff, please enter their name’

User enters the names

Then it goes to the next step. There is no actual PII included in the prompt.

1 Like


Well, I would wait to hear from them. Maybe you got hit with a false positive filter asking for the name?

If you have another one, you might try to replicate without asking for the name? Just a thought.

Again, good luck.

Thank you @PaulBellow .

This issue affects all my custom GPTs, they won’t update with any new knowledge and I cannot create a new custom GPT because they too have the same issue with updating themselves to reflect the knowledge given.

I’ll wait and see if OpenAI responds and what they say.


Now I’ve encountered a number of issues with custom GPTs, such as GPTs that should only describe artistic or technical styles. and in-depth information Tests at build run normally. But when they came out, they refused to use the same link and the same commands.

and GPT that creates educational tests. But it refuses to check the content from outside data. When the builder can fix it, it can’t be done either. It’s been a problem for 1-2 days now.

Another personal one that I customized. Do not accept any work related to websites or links, but the ones that other people make from the store, if they have action, can still work.

1 Like

I am also unable to make changes to my customGPT and getting “Error Saving GPT” when I click the update button.

Initially, I thought maybe this was happening because I moved from the Plus subscription to Teams (workspace plan) but it appears the problem is not related to the plan but the whole system.

Waiting for this to resolve :cold_sweat:

1 Like

@Shaharyar Glad I am not the only one here.

Yes, all we can do is wait.


Hope everyone sticks around. We’ve got a great community garden growing here - lots of treasures to be found wandering the rows! :wink:

Also hoping you get answers shortly…

1 Like

I noticed that the problem is dynamic. Because it is not constant, it disappears and returns.

I have tested various environments.

About 15 minutes ago, work on the link returned to normal. But I ran out of messages.

1 Like

it feel custom gpt will have more problems and be stupider.

GPT 4 has better and more in-depth file management. When multiple documents are received, data analysis is used to process them one at a time, while GPTs are stupid and cannot even imitate because they do not listen to commands. I tried every method but still put everything together and pull the data. The result is only one document, or if data analysis is used first, it will be done all at once. I opened and looked at the working process. It appeared that it selected only the first part of the document’s text to use. (What do you think we’ll get from the table of contents?)

1 Like

@chieffy99 I’m trying to make a custom GPT to create a shift roster. But there are a few conditions and rules.

Did you try listing everything in sequential order in extreme detail? I’ve gone from writing what I want it to do (back when it worked) in detail, to literally breaking it down into very small pieces and then getting it to echo back to me what it learnt as verification before moving to the next step.

Sometimes, explain to the custom GPT like it’s a child can get better results, but still not perfect.

I’m also brand new to all this and so I am probably talking rubbish!

1 Like

This should tell you better.

The photos that refused to come out of the internet were the ones that had problems earlier. The pictures that answer in sequence are pictures that are normal behavior when starting a conversation. But do you know what I encountered before I could return to using the link?

I wrote the steps as you see but it avoids requiring the user to upload files one at a time. That’s 5-8 hours of wasted time.

I want to show you the first live chat. It cannot be published with a link because it contains images. It worked better than I expected, so at first I thought I’d save my answer so I could check the results myself. This is because most GPTs from monthly accounts have a small window. Makes it impossible to remember much of the previous content, but this one takes the notes it made and calculates it. Including very little error in work.

After that, the problem coming. Large expansion points to the extent that the content used does not match the document, but after working with the link It knows without the browser that the link contains information to be created.

1 Like

I just created a new custom GPT for myself with “configure” to use at work. I’ve created dozens. But for the first time, I went back to “edit” the GPT with “configure,” and my entire instruction set, commands, and conversation starters had been rewritten. The essence of them still exists, but it looks like the GPT decided to do a “create” overhaul. It’s very annoying as it is a writing GPT - and I know that the way the GPT is written and configured will impact the output. I can’t understand HOW this could even happen.

1 Like