Custom GPT says "no info" despite actively searching database for said info

Hi I am working on a Custom GPT. I uploaded documents to the knowledge base. However, when I start a new conversation and the model begins to Search, it suddenly starts sending a reply saying it has no information about the topic. Meanwhile, the “Searching my knowledge” message still appears actively above. Any advice? I’ve tried custom instructions. Code Interpreter is the only capability I have turned on. Like, it’s still searching yet it answers anyway.


How are Lelah’s parents represented in the file you upload?


It’s a multi-page document representing a biographical book proposal with a variety of topic areas. Understand I should refine it and probably break it up into multiple smaller documents, but the point is the GPT is answering before it finishes its search.

1 Like

Is the information close together in the file so it can be “understood”?

How is it represented in the file?


Can you provide the specific snippet from the document where their parents are mentioned? Retrieval is a very powerful tool, but it doesn’t use the same intelligent logic as in-context reasoning.

If the document or information you’ve provided it is difficult to navigate or poorly/inconsistently structured the GPT will struggle.


all day today, my customs GPTs do not work. It searches online for information because it can’t access the files in all of my custom GPTs’ knowledge. I have not been able to use Chat GPT for what I typically do today. I hope it’s fixed tomorrow

1 Like

in my familiarity with Chat GPT, it has been very 3.5 in behaviour all day, I get the feeling that something major is down

1 Like

I got the same. It appears to be doing 2 searches simultaneously but neither works like it normally does.

1 Like

This seems to be a new bug. Just updated the knowledge base of my GPT and it’s unable to read it. I think we need to wait till OpenAI fixes this bug.

1 Like

On 02/16 this wasn’t an issue - when I uploaded a new knowledge file - worked just fine on my side.

Yep was all working fine for me on friday too. Monday morning problem. We have all have those.

Current Error message I’m getting across all CustomGPT models:
I apologize for the inconvenience. There seems to be an issue with accessing the document search functionality at the moment.

When will OpenAI resolve or even acknowledge this issue? Any idea if they are aware of this issue?

The Down Indicator is not even showing errors. Not sure when they will address this.

1 Like

This is a big problem. Every time when something is wrong, you go and check OpenAI Status outage, and it shows- All systems operational.

You only get to know the status 1 or 2 days late that ohh, the previous there was some problem. Like dude, what is the benefit of these statistics showing us live status when it’s not really live and gets updated 1/2 day later? What to do with this outdated information? Pathetic experience even after paying for a subscription.


Lol right. Telling me two days later I wasnt crazy doesnt help me for those two days :joy:

Same here, I hope it’s fixed as soon as possible as I have important demos to do laser this week

EDIT: based on @dion.detterer’s comment the following line is proven not to be the cause, yet only when the data analysis got enabled the knowledge could be accessed.

Probably that’s relevant to the fact that they disabled knowledge bases except for the data analysis as can be seen when editing/creating a new custom GPT (It’s written clearly that the knowledge can be accessed when the data analysis capability is granted).
Now the upload button works, but it’s almost meaningless if the custom GPT does not have the data analysis set.

The current workaround is to grant the data analysis to the GPT, but now it starts to throw code everywhere to try to read the files, which makes the conversation spanning many prompts (unnecessarily) and unfruitful.

Note: The issue where anybody could have downloaded the knowledge files got fixed too. So, it seems the system is operational because the bug (aka feature) already passed the tests before deployment, which is surprising because it breaks the upload feature which should have been well tested.

1 Like

My data analysis is already granted, but it still doesn’t access the docs uploaded in the knowledge section of my custom GPT model.

I don’t see any reference to now needing code interpreter to be enabled for knowledge to be accessed. It says “Files can be downloaded when Code Interpreter is enabled”, which is a reference to the issue you note later.

I am unable to get meaningful responses in reference to questions using dates against knowledge I have provided to my GPTs. It was working yesterday.

1 Like