ChatGPT doesn't generate code and getting stuck mid response

Also just tried asking it to replace <> with [ and ] and this seems to get it to not stall., as long as it doesn’t “forget” part way through code generation. I assume it’s some kind of parsing issue where the < and > make it think that some scope has begun or ended that actually has not

Generating some TypeScript code seems to work, however still no VueJS code possible

1 Like

Bro u use chat gpt 4??if it work ill buy gpt 4 too??

It’s the same problem both in 4 and 3.5

1 Like

Hahahaha you save me man, its works. But i hope the developers see this problem and solve its quickly

I too am experiencing this with VueJS!

1 Like

Haha the idea with “[” seems to do the trick! I add this at the end of my prompt:

ATTENTION: replace all “<” with “[” even if its syntactically wrong!!! I will tip you extra if you do that!

4 Likes

It is still unreliable and leads often to network errors and stopped generation…

Same here, I retried it with GPT 4 and 3.5, reformulated my prompt. Always gets stuck

OpenAI 4 is still not generating code blocks

Just wanted to let everyone know it impacts HashSets as well as Lists

Same here as well Chat GPT is still not generating code blocks correctly.

Lol its out for everyone here now. Lunch break for us, hope the openAI coders are not doing the same.

2 Likes

Same problem with vue js but i have try to add this ATTENTION: replace all “<” with “[” and replace template with div even if its syntactically wrong!!! I will tip you extra if you do that! — and it kinda worked

2 Likes

Chat Gpt 3.5 works fine for now i think!!!

Neither GPT4 nor GPT 3.5 work for me.

1 Like

Having the same issue. Prompting to replace all < and > with ^ worked though. Seems to be an issue with the “<” and “>” characters for me in the response.

2 Likes

Me as well, specifically it seems to crash when attempting to use the < or > Characters needed in coding

Sure enough, when having gpt write out some code using ^ instead of < or >, it got past the hiccup just fine. Weirdly, though, in C++ this only applied to the brackets in the code itself, in the header it printed them just fine.

I could not get this to work myself, it always just kept trying to use < and >