Chat History == Off gives error "conversations created when Chat History is off expire after 6 hours of inactivity"

I am an individual plus subscriber. I am using the sub with Chat history turned off. Earlier today, I was getting error that said “Conversation key not found”. I tried different browsers, fully updated, cleared cookies and cache etc. No difference. I posted in the forums earlier and seemed other people had the same issue.

It seemed that by 10PM GMT, the error was gone but only briefly. Now I am getting another error as below. Screenshot is also included. This is erroneous because the messages are sent within few seconds of each other.

I know this is a beta stage product but can the devs please stop messing around the frontend settings of those with chat history off? Two different errors back to back came up today and both correlated with chat history off. It’s quite frustrating.

Error Message
Sorry, conversations created when Chat History is off expire after 6 hours of inactivity. Please start a new conversation to continue using ChatGPT.


Same. I can’t ask more than one question per session at the moment with chat history disabled. It either shows the expiration error, or the key not found error.


I first experienced the missing key error a week or so agolike you mentioned. After over 100 posts on that thread, they fixed it… And now I’m encountering the expiring after six hours error. The message appears every time, even when sent immediately after getting the first response. Ugh. This is making me pull my hair out! OpenAI - either keep the app working correctly when chat history is off or give us another way to protect our employers from data leaks. I’m not turning on chat history when I’m using the product for work. The frequency of these types of errors, which make the product nearly unusable, is becoming unacceptable.


i get this after every message now, it really bothers me why even pay when it is like that.


Yep, I’m getting this error as well. It’s basically the same error as the one I posted about weeks ago, but with a different message:

OpenAI, I see some of your team liaisons replying to other threads on this forum. I know you’re aware of this issue. The fact that you’re not acting despite the significant documentation for and reproducibility of the error does not reflect well on you and is making your users assume the worst. Please fix this ASAP.


I experience the same issue and really hope this will get fixed very soon.


I need to keep my Chat History turned off for secure use. These problems only occur with chat history turned off.

I have had all the same problems over the last two weeks, starting early February. Currently, immediately with the second query in the conversation, I get the “something went wrong,” followed by “Conversation key not found.” And similarly to others here, I get the six hours past message when in fact my conversation is still within an hour of use. My paid version of ChatGPT4 is unusable as such.

(I have cleared the cache, cookies, and everything else offered as help ideas)

How do we find out if anything is being done about this problem?

1 Like

I am also experiencing the same issue. It is pretty annoying. I hope it gets fixed soon. It happens with me every time I put the second question.

1 Like

Yes, same here. It happens with the second query.

1 Like

Getting this error with every second message. Can’t use ChatGPT like this. Please fix! :pray:

1 Like

same error I am getting. what to do?? can anyone help?

Samesies. This error makes chatgpt unusable

I requested a 90% discount on this past month from Open AI. If they don’t get back to me by next Wednesday, I will dispute the charge on my credit card – there’s no reason to pay for its entirety because I’m not getting the service I was sold.

I’ll also report to FTC and about the false advertisement of the service. Whether it’s nefarious intentions or incompetency, it’s messed up that just because we want data privacy, we are served a terrible experience.

I recommend all of you dispute the charges on your credit card and report to the FTC. This is not what we paid for.


This is not something that should require asking or pleading at all.
It was designed to work correctly in its essence, and it’s not your fault that it doesn’t, so please don’t worry🙂

Hey folks, we rolled out a change that should have resolved this. If you continue to run into issues, please let me know here!


Not fixed…

1 Like

I just created a new account about an hour ago. Am still experiencing this problem.

1 Like

Still not working. The model is also getting worse and I wrote support more that 14 days ago with no answer. Not impressed.

More documentation about this issue available here: