Builder profile: can not enable a verified domai

I verified a website but can not enable the link to be shown in the builder profile and in the publicly shared GPTs. The “Links” toggle switch is disabled.

You can delete all the domains and save.

Then go through the process of adding a new domain. Getting its TXT record to place in DNS. Waiting for propagation of DNS info by your DNS expiry setting. Then pressing verify in the dialog that remains open, all in a short time span.

That should get you going.

I already tried deleting all domains and going through the verification again. This doesn’t help.

The next step or alternate step they say is to fill out all your billing preferences in, give your organization a name, etc. If just nothing will work and that one toggle is there even with a login again on a different browser and session, then it must be some account problem that the help in the account menu might be able to rectify.

It’s clearly an OpenaAI bug and not an account problem. The site is verified according to OpenAI instructions. As you can see there’s no verification errors/warnings. Also, I tried different browsers, cleared cookies etc.

Also, I built 30+ GPTs and previously had no problem with the website link, but after I changed the website url, the toggle stopped working.