Are localhost plugins crashing your browser?

All localhost plugins seem to be running up the Chrome CPU usage and crashing it, once there’s a response from the server. Even an empty or simple text response, including vanilla starter plugin example crashes immediately.

When I come re-open ChatGPT, the response from the crashed tab will show up under “New Chat” as the first message of the new chat. If I try to respond it’ll say “Conversation not found” or something similar.

Is this… a bug on my end??


Yup, I spent the whole day assuming I was doing something wrong in my openapi.yaml untill I finally tried firefox just to check my sanity, and Voila!
Hope this gets fixed soon…

1 Like

me too, I thought my code was bad haha. I guess we’ll just hang tight and get back to doing some real work :stuck_out_tongue:

1 Like

Getting the same effect. I don’t think it is the custom APIs themself. All of the API calls on my end complete. But after GPT gets the data, it hangs for a little bit, then crashes.

Yeah it’s the GPT-Plugin model that’s crashing. If you monitor traffic, so see it receive it properly, and then it just jacks up GPU/CPU and Chrome kills it

1 Like

Arrrgh! yesterday it was only crashing chrome, but firefox was ok. Now it is crashing both!

Eventually, this starts happening on every plugin request.

“Empty cache and hard reload” seems to be a temporary fix. Though, it starts happening again within 10 requests.

Edit: also seems to be worse when “expanding” the request/response element for review.

attn @logankilpatrick

1 Like

It seems to be getting worse. Localhost plugins are effectively unusable for me at this point.

Things I’ve tried:

  • clear cache & hard refresh
  • incognito window
  • re-installing the plugin

Based on very limited testing, it seems if I open both the openai debugging tool AND chrome browser developer-tools debugger, my plugin seems to work, even after 5 calls. It had been crashing the browser immediately on response from the first call. Kinda awkward, the two debuggers take up a lot of screen real-estate, but at least I can continue working. We’ll see how long before a crash.


Weird, but yeah, this seems to be working

Oh that’s a good point. I should mention I was using edge which is chromium based.

@bruce.dambrosio @wfhbrian Thanks for sharing your solutions. I’ll try them out today.

Might not actually need both, I haven’t tried just one or the other, just happy to be able to move forward…

1 Like

There seems to have been a UI update (the bottom left corner now expands to show settings). The tab has crashed after every plugin request since the update.

Both CPU and memory increase right before the crash. Chrome memory utilization quadruples from 400mb to 1.6gb. CPU usage increases maybe 2–3X.

1 Like

Yup. Sigh, back to square one

Interestingly, the last call made before the crash is to moderation. Hmm

1 Like

I think that’s the standard operating procedure.

I just checked my network tab, and the call to the localhost API request responds as expected.

Then two calls to the OpenAI /conversation endpoint occur directly before the crash. Considering that erroneous conversations appear in my chat history, the bug probably has to do with these requests to /conversation.


1 Like

Example erroneous chat in history

Edit: Unconfirmed, but it might occur when a second API request is made immediately after the first request. @logankilpatrick

Update: WORKAROUND: Resubmit the same prompt by clicking “Edit” and “Submit” after refreshing after the crash. Seems to work after that.

posted this in the other thread by accident, but after refresh I just see a blank new chat window, no original input or edit or resubmit. Did I miss something?