Able to verify Apex domain but not subdomain for GPT builder

Hi all, I’m having a problem with domain verification.

So I’m able to verify my Apex domain i.e. and that works fine. I created a TXT record at the root of my domain and had no problems at all.

However, my website is at and it’s a CNAME pointing at GitHub pages. If I try and verify it simply doesn’t work. I can’t have a TXT record pointing at because you can’t have both a TXT record and a CNAME and it looks like verifying the apex domain by placing a TXT record for doesn’t verify

I also can’t point my Apex domain at my www subdomain because Apex domains don’t support CNAMEs.

I’m a bit stumped.

Is this for GPT builder actions? Are you saying a GPT can’t make an action with an API call using the domain you own, is that what I’m getting from this?

No, sorry if I wasn’t clear. I’m taking about creating a GPT. To make it public you need to either use your legal name from billing, or verify a domain.

This sounds like a domain configuration problem more so than a GPT or OpenAI problem. You might be able to see if you can request support here (OpenAI Help Center), but otherwise, we’re not going to be able to help you with this problem on this forum very well. It’s just not really in the scope of what we know nor what we help with typically.

1 Like

Thanks for the advice. I think I ran into a limitation of DNS. To verify a domain you register a TXT record, but subdomains (like www.*) can’t have CNAME records and TXT records at the same time. Mine does, so can’t be verified.

1 Like

I’m sorry to hear that.

I did verify my own website last night to see if I could try and identify a solution for you, but I’m not a web expert guy, so I still couldn’t interpret how to solve your problem on a technical level.

However, you did specify is verified fine, correct?

What about redirecting your root domain to the www subdomain? Whereby your root domain serves as your verification, but when it’s clicked, it just redirects to the

1 Like

Hi Macha,

Thanks for looking into it for me. That’s really kind of you. Unfortunately you can’t use a CNAME to redirect a root/Apex domain to a subdomain using a CNAME, and ALIAS records aren’t available if you use DNSSEC.

I’d usually redirect on the web server, but at the moment I’m using github pages.

I have had an idea though. I guess I could use the cloudflare free plan to redirect. I’m going to give that a try.

Thanks again!

1 Like

And just in case anybody comes across this question looking for a solution.

If you want to redirect from your root/Apex domain to a subdomain like www using a CNAME you can’t do that according to DNS standards. Neither can you use an ALIAS record if you also want to use DNSSEC.

The solution that worked for me was to a signup to a Cloudflare free plan, point DNS at Cloudflare and setup a URL redirect: Set up redirects · Free plan · Learning paths (

1 Like

www mydomain com verification is not working for me either even after 24 hours. I added DNS for TXT. I have another google verification TXT value as well.
When i try to add [https: // yourdomain dot com] without www, I get an error that it is not valid domain.

Hi legend,

So you’re trying to verify and you’ve added a TXT record to the www subdomain of

If you use to check does it show the TXT record you put there?

Are there any other records at, or does it just contain an A record pointing towards your web server?

Resolved: Added without https or www and then was instantly verified adter adding TXT to DNS

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.