429: insufficient_quota - When enough quota and credits are left

Since today I get the error that i have passed the quota, even though im well within the limits. Have not had this issue before in the past months.

I am using model gpt-4-1106-preview model, currently at Tier 3 with 2 million tokens spend today, not even reaching 5 million in the past 2 days.

Hopefully this can be resolved soon, I read about others having this issue in the past because of a bug.

1 Like

Similar situation for me. At some point I started to receive 429 (from api.openai.com): “You exceeded your current quota”

When I checked the Usage/Activity (in https://platform.openai.com/usage) - it was completely blank even though I used GPT since summer 2023. Assistants page was also blank (before that I had a couple of assistants configured).
OK, due to the urgency I added 20$ to a blank account. No changes. 429.
I created new API keys - didn’t help. Still 429 when using the API.

Interestingly, https://platform.openai.com/playground works.

Customer support answered the initial question with some generic “looks like a temporary glitch or system bug on our end”. No updates since 12.01.

For more details, the test curl looks like:

curl --location 'https://api.openai.com/v1/chat/completions' \
--header 'Content-Type: application/json' \
--header 'Authorization: Bearer my-new-api-key' \
--data '{
  "model": "gpt-4-0613",
  "messages": [
      "role": "user",
      "content": "How much is the fish?"
  "temperature": 1,
  "max_tokens": 1024,
  "top_p": 1,
  "frequency_penalty": 0,
  "presence_penalty": 0

and the response is still 429:

    "error": {
        "message": "You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs: https://platform.openai.com/docs/guides/error-codes/api-errors.",
        "type": "insufficient_quota",
        "param": null,
        "code": "insufficient_quota"

Just realized that the documentation about rate limits has been updated.
Hope this helps you understand the

In addition to seeing your rate limit on your account page, you can also view important information about your rate limits such as the remaining requests, tokens, and other metadata in the headers of the HTTP response.


1 Like

Problem is that this is happening not to the free tier, but for the paid plan.

1 Like

I get the same error, even though I have barely used my paid credit.
I am using the gpt-3.5-turbo model. Is there a way around this?
Yesterday it was working fine, but now I get the error.


Same issue support does not give a s**t.
Paid account.


I see what’s going on here now. OpenAI has changed how “Pay as you go” is processed. They want their money up front vs getting billed at the end of the month for only what you have used.

Make sure you have “Auto recharge” set to “on”.


I found this thread looking for a solution. I also keep getting the same 429 error, even if I barely used chatgpt lately. The chat interface works fine, but I get this error when I try to use the API (I am using Alfred on macOS with a workflow). I am a free user, but everything worked fine so far.

Is there a different quota for api keys that does not apply for the classic web chat gpt?