Why is GPT4 not reading Excel files?

Yesterday, in the midst of doing some data analysis, all of a sudden I was told that

" It seems there was an error attempting to load and display the data from the CSV file. Let’s try loading the data again and inspect its structure. I will attempt to read the file again. Please hold on. ​​

Error analyzing

▸I apologize for the inconvenience, but there appears to be a persistent issue with accessing the CSV file. I am unable to load the data at this moment."

I tried other formats, but the GPT is saying that it’s just not reading these files at the moment.

Is anyone else having similar issues and has anyone found a solution?

Hi Allen. Yes for sure. Most every developer utilizing Beta versions of the api including myself have experience similar error messages occassionally.
Sometimes you will encounter errors with the beta versions of the api that has nothing to do with a particular file type. Generally the issues have to do with to many users trying to access the api, their upserted RAG (retrieval) documents, and or Code Interpreter. You can also encounter this same issue in ChatGpt Plus from time to time. I would suggest trying to run your GPT and access your csv or excel files during different times of the day or night and see if you experience the same errors. All the best

2 Likes

Cheers.

I appreciate any insight. It seems like it’s been coming in and out, but this is the first time I’ve been pushing it for data analysis of more complex sheets.

Even when I tried to cut it down to the basics, it just couldn’t read it… even though it could before. This makes sense based on what you wrote.

I’ll keep trying

Thanks again.

Most welcome.

I am fairly positive that it has nothing to do with your data files if they were working initially and are not working some of the time now.

I would suggest testing the same initial documents in the OpenAi Playground https://platform.openai.com/playground.

Yes for sure. Keep testing, keep trying, practice patience and enjoy the process.

No matter how much experience any of us have, all of us run into errors, problems and challenges.

One of the best aspects is that developer communities are almost 100% very supportive of and helpful to other devs.

Best regards,

1 Like

Hi,
I have today encountered a very similar issue. GPT-4 is not processing .csv or .xls. files.

I am receiving messages like “I continue to encounter difficulties in reading the file “Book5.csv.” The persistent issue suggests that there may be unique formatting or encoding issues that are not compatible with standard CSV reading methods.”

I cut the files down to the simplest form and still get error messages.

Any hint on how to deal with this?

Thank you.

1 Like

Hi,

I just read your message. Can you share the file with me and I can test it out on my end for you?

I rather ask him to write a code that i can run in colab, and the snippet of dataframe this case.