Usage is temporarily unavailable, please try again soon


The usage on our account has increased 10x today, but the traffic is not coming from us. Looks like someone got our key, but we can’t tell because the usage reports are not working. We get the error “Usage is temporarily unavailable, please try again soon.” We’ve seen this error before and trying again soon doesn’t help. Can anyone from the OpenAI team help with this? (I would ask support for help but we have 2 requests into them that we sent 30 days ago that have not been answered.)


1 Like

OpenAI states that in case your key is leaked, the very first step is to revoke/rotate it.

Then contact support with relevant details.

1 Like

Thanks. We have revoked it. I would like to see the traffic/usage that is causing all the spend. We believe it’s GPT-4 traffic as our account has access to GPT-4, but we don’t any public applications that use that model at the moment.

Now we cannot see any of our usage. No idea how much we are spending right now. Here’s the error message we are seeing “Could not fetch usage for this organization, if this issue persists please contact us through our help center at”

I face the same issue on all my accounts when I select a day in “Daily usage breakdown (UTC)”. Revoking KEY does not solve the problem.


We are facing similar issues - usage has gone up by a huge amount. we have revoked keys and the new key has not been used. we are still seeing activity on revoked keys

Hello OpenAI Team,
We are running into the same issue, it seems one of our API keys must have been cracked and who ever did this used all of allowed Usage limit. We have been trying to use support to talk to someone and no one gets back to us. We changed all of our API keys, but we cannot see the usage per user because the system does not work. You have spent billions on the most advanced AI model and you can’t figure out how to do a simple usage request or get back to the users that are paying for your service, this is a disgrace.

1 Like

Hi, I’m having the same issue. What’s going on? I can’t see my usage history per day and it’s been shooting up over the weekend, when clearly no one on my team was using the API at all. Is this another hack? Please advise.

I also have the same issue, I think it’s a bug. I speculate the main reason might be that someone used the organization’s APIkey within the month, and then this guy was removed by the Owner, leading to a mismatch between the Daily usage and the Daily usage breakdown.


This is happening to us as well, usage has skyrocketed this month and our complete monthly quota was exhausted by god knows who, we also noticed slightly increased traffic since mid March, at times when clearly none of us were using any of the models. OpenAI customer service is terrible, no one reached back out to us in more than 2 weeks.

I have the same problem.
All of a sudden my API usage spiked to 10.
It doesn’t even show who used it.
Is this an error on OPEN AI’s end?

Yes, I have the same problem
I also get the same error: “Request failed with status code 429”

same here. on the 22nd and 23rd of may i somehow accrued enough usage to hit the hard limit on my account. however, i barely used the platform on those days. i reached out to openai on the 23rd and 24th, but still no response. still unable to view usage.