Unable to upload files for GPTs - error saving draft

Hello!

I’ve created an personalised GPT.

when I try to upload pdf file, I succeed to upload 2 or 3 of them.
After then, I have a message “error saving draft”.
Is there limits in the number of files? In the size of each files? In the size of all uploaded files?

Do I make something wrong?

Thanks for your answer

5 Likes

I have the same problem, even without uploading PDFs. I cant save changes anymore.

Same here, I get this error message whenever i try to upload pdf’s. Is there a solution already please?

My GPT works well few hours ago, and now it is showing I have 12 repeated documents. And it always shows “Error saving draft”, no matter what I have change in my configuration.

I have the same problem, I am always getting the same error message no matter what

Still having issue uploading files and being able to save draft. Occurs with either uploading in chat prompt or in configuration page. Was working ok about an hour ago.

Here’s the solution that worked for me as I was having issues saving drafts for the last 12 hours.

It appears that openai made changes in their logic regarding actions and external APIs.

I opened up my browsers inspect/console to see what error I was getting. I saw a message saying akin to “Error! You can not have multiple actions using the same external API”

I just deleted my action/api as I didn’t really need it and it solved my problem. I can now save drafts.

I have no API’s and was still having this issue. I think its more intermittent with the service or just a bug in the development overall.

I was able to upload multiple PDFs on Saturday for my first GPT Assistant with no issues. On Sunday, I trained another GPT and at some point, after I had successfully uploaded 3 or 4 pdf files, it started giving me the “error saving draft” error. I asked the Builder what I can do and it recommended copy and pasting our full chat thread to save it somewhere else and then reload the builder. The builder was able to point to the last upload and instruction that was saved before the error so I tried uploading a file again. I tried different files, different browsers, different login sessions, different days but I still am unable to upload files when I edit the second custom GPT.

UPDATE: As of 11 am PST on Nov 14, I no longer see the option to edit my custom GPTs. Did OpenAI just roll back the custom GPT Builder because it was breaking? (I would guess it’s getting hammered).

working for me now, yesterday was pretty slow and ran into a lot of problems. but reduced the amount of files i was uploading as well and that seemed to help

I am having the same issue, can’t see if it is certain files, the number of files or a system outage.

According to the GPT builder, it can hold a maximum of 5 files.

I created .pdfs to hold merged files to give my GPT more data, fixed the problem.

1 Like

What is really strange is the fact that GPT builder says he CAN SEE the uploaded file, but still impossible to save ->Error saving draft. This is starting to irritate me. And it is not about file size !!! Moreover if you try to fix it directly with GPT builder you quickly reach the answer limit. This is ABSOLUTELY inacceptable for a paid service!

Only 10 files.
YT /watch?v=4lr331g695s

CONFIRMED!

1 Like