Unable to access "My Plan"

Hello all, I am unable to click the “My Plan” option in order to cancel my monthly subscription to GPT4. I am a little shocked by this to be honest. Does anyone have the URL handy? I have tested on mutliple browsers.

2 Likes

I’m not looking to cancel my subscription right now, but I wanted to see how many days I had left this cycle earlier, and I can confirm that My Plan hasn’t been accessible for at least 7 hours.

1 Like

I am having the same trouble. Is it a bug? Why can’t I make a shorter sentence to reply?

+1 I have permitted pop-ups for the chatgpt site and also for all sites, but when I click on “My plan”, you get nothing, no modal for managing your plan. The other options work fine–“Custom instructions”, “Settings & Beta”

Same here. I am unable to get access to “my plan”.
Now i am more angry than before.
I want to cancel the subscription now, because the availablity of gpt4 functions is very short / low.
Today I generated very 4 images, talk-tested own gpts and - wham - over for the next 2 hours. Very bad for this price.

Okay, I gave in and cleared my browser cache and that fixed it. Dumb.

I didn’t do that and I can access it, so it looks like they just fixed it.