Topped up 50$ but my Account is still not Tier-2

I topped up 50$ and waited more than a week but my GPT3.5 requests are as slow as before.


How can I be sure that I became Tier-2?

Go to rate limit page in your account, which is under settings. Tier is there. They won’t tell you “add just $0.05 more”, though.

Tier 2 $50 paid and 7+ days since first successful payment $500 / month

Although paying and instantly getting bumped up happens, the rate page also says you aren’t immediately moving forward if you only recently made your first payment.

I have the same issue. Tried adding more than 50$ to see

Although you see your credit balance in your account overview, you may need to wait a bit for the payment to actually process and be charged to your card.

OpenAI or their payment processor seems to have queued the actual card processing (and the follow-up account activation to new thresholds). This can be quite apparent when a new user pays, but then still can’t use the API at all.

You can watch your bank statement online as the signal that it went through.

It charged from my card like a week ago, almost immediately after I bought credits. I wrote to support yesterday but they still didn’t contact me back, usual OpenAI support experience :slight_smile:

Please let me know if adding more than 50$ works, maybe they want like 50.01$ kind of payment to activate next tier, I don’t know…

Note the 7+ days part

I know that part. It already passed 1 week.

Not only it pass more than a week for the first payment, it also passed for the second payment which completed the sum of my payments to 50$.

I note you have already reached out to support, if that was via the support bot on, then you have done all you can for now, they will get back to you, huge uptick in users and support request after devday so please bare with it.

1 Like

I’m in the same boat - topped like this:

Still no tier 2.

Support is not allowing for filling out the usage limit rais form anymore. (had a screenshot for that as well but I cannot add more than one.

Hi @oynozan,
I can see it’s been a month now, has this been resolved now, was there anything you needed to do different?

I have the same issue