Problem reaccessing / reuploading files to GPT 4o?

Yesterday, I tried uploading CSV and XLSX files to a previous conversation and it was impossible, as it was always giving an error saying he wasn’t able to access them.
Then, I started a new conversation and uploading and analyzing the files there worked just fine. I have a bunch of instructions on how to read and process the data / columns in these files and the experience was great.
This morning, I come back to the same conversation and once again, I get errors accessing the data, and it won’t read and process the same files I’m trying to upload again.
In a new conversation it works fine once more, but I don’t want to go over all the same troubles of teaching this new conversation how to read and process the data.

Here’s what the previous conversation suggested me to post here.

However, I’ll now detail the issue, so it’s clear for the support team to investigate and resolve:

  1. Issue Description:
  • Persistent failure in accessing uploaded files within this conversation, despite multiple attempts with different methods (pandas, openpyxl, pyxlsb).
  • Similar issue resolved in a different conversation, indicating a potential environment-specific problem.
  1. Steps Taken:
  • Attempted loading files using pandas and openpyxl libraries.
  • Tried reading file paths and inspecting directory contents.
  • Multiple re-uploads of the files, but the issue persisted.
  1. Outcome:
  • Unable to read or process the files.
  • Requires support to investigate potential environment-related issues or file handling processes.

I need this conversation to work again! How do I do this?

I had the conversation try to generate a load a simple file and it told to report this error.

Given that even a simple test file encounters issues, it confirms there is an underlying problem with the current environment. This problem needs to be reported to OpenAI support for investigation.

To ensure this is properly handled, please report the following details to the OpenAI support team:

  1. Issue Description:
  • Persistent failure in accessing uploaded files, including simple test files, within this conversation.
  • Multiple methods and approaches attempted (pandas, openpyxl, pyxlsb) without success.
  1. Steps Taken:
  • Attempted loading files using different libraries.
  • Repeated file uploads and environment restarts.
  • Encountered consistent KeyError exceptions, suggesting a potential environment issue.
  1. Outcome:
  • Unable to read or process any files in the current environment.
  • Issue confirmed with both user-provided and simple test files.

You can report the issue to OpenAI support through the OpenAI support page. If there’s any additional information or specific instructions you need, please let me know, and I’ll assist you accordingly. ​

From this code it generated:

Create a simple DataFrame for testing

test_data = {
‘Column1’: [1, 2, 3],
‘Column2’: [‘A’, ‘B’, ‘C’]
}
test_df = pd.DataFrame(test_data)

Save the DataFrame to an Excel file

test_file_path = ‘/mnt/data/test_file.xlsx’
test_df.to_excel(test_file_path, index=False)

Attempt to load the newly created Excel file

test_loaded_data = pd.read_excel(test_file_path, None)

Display the sheet names to verify the structure

test_loaded_data.keys()

I’m experiencing the same issue and it’s frustrating.